WordPress.org

Forums

Moving blog - Trouble with design (5 posts)

  1. alexsjaan
    Member
    Posted 11 months ago #

    Hi there,

    My company previously had a website with a blog managed via WordPress. Now, we're in the process of moving the entire site over to WordPress. This task has fallen largely on me and I'm not entirely WordPress savvy. I know enough coding to not be completely lost.

    So, I've managed to get everything else set up. Got the design to match, etc. What I thought would be the easy party is turning out to be the hardest part yet:

    I can't get the original blog design to work. I've read through the Codex on page templates, messed with code and settings. I can't get it to format. I'm totally lost.

    Since the CSS and HTML between the two sites is nearly identical, I'm not understanding how this could be failing.

    If someone could just point me in the right direction or explain why nothing I try is working, I'd really appreciate it. I'm not completely helpless, but I could use a step up!

    Old site: http://simpson-direct.com/blog

    New site: http://beta.simpson-direct.com/blog

    Thanks!

    Alex

  2. CrouchingBruin
    Member
    Posted 11 months ago #

    Hi, Alex. So the old site looks like it's using the Twenty Twelve theme, but the new site is running a custom theme that you've put together? Why didn't you start with Twenty Twelve on the new site? Or did you create a child theme of Twenty Twelve?

  3. alexsjaan
    Member
    Posted 11 months ago #

    Hey, thanks for the response. The old site only used WordPress for the blog. The rest of the site is not built in WordPress, so it didn't have anything to do with the Twenty Twelve theme. When I started to move the bulk of it, it seemed easier to develop a custom theme.

    The custom theme isn't a child theme, but it is based off of the Twenty Twelve theme. The style.css file is largely changed as well as header.php and footer.php. Everything else is the same as Twenty Twelve. In retrospect, probably not the neatest way to go about this project, but it was working wonderfully up until this point.

    Alex

  4. CrouchingBruin
    Member
    Posted 11 months ago #

    OK, so you're probably missing a lot of CSS rules which are in the TwentyTwelve stylesheet that you may want to copy over. For example, the reason why the text isn't flowing to the right of the image is that you're missing the CSS rules for image alignment classes:

    .alignleft {
    	float: left;
    }
    .alignright {
    	float: right;
    }
    .aligncenter {
    	display: block;
    	margin-left: auto;
    	margin-right: auto;
    }

    What I would do is use a web debugging tool like Firebug or Chrome Developer Tools to see what rules are missing for each element, then work back & forth between the two sites, copying over those CSS rules that you are missing. You can also try copying over the contents of the TwentyTwelve style.css file, but hard to say if you will have any conflicts with your existing CSS.

  5. alexsjaan
    Member
    Posted 11 months ago #

    Wonderful! Thank you, that helped so much. I haven't gone through with a debugger yet, but I did manually compare both stylesheets and update my current one. Things are progressing.

    What's interesting to me is that copying over the "Editor" code for style.css from the old site does not "fix" the blog page for the new site. So there's obviously other code I'm missing. I thought it was the blog template, but that doesn't help either.

    It's a mystery. But I'm much closer to solving it.

    Thank you!

Reply

You must log in to post.

About this Topic

Tags

No tags yet.