WordPress.org

Ready to get started?Download WordPress

Forums

Moving blog from subdomain to it's own top level domain (10 posts)

  1. Snow
    Member
    Posted 4 years ago #

    I've been running MU for a year and half, and recently upgraded to the integrated WP3. I've just hit the problem of not being able to move a blog from a temporary location as a subdomain, to its permanent top level domain location. Here's what I used to be able to do (all links included below are made up for example purposes, none are real domains that I run):

    1) create and develop here: dev.mydomain.com/tools
    2) when it's done and ready, create new/empty site at permanent domain (toolsdomain.com) in same MU system,
    3) move blog from dev location by using the Assign Blogs link on (what is now) the Super Admin > Sites (bottom one) page
    4) your new domain has 2 blogs now, delete the newest empty one, keeping only the one moved from dev.

    Since upgrading to WP3.0.1 it seems this function is broken. Now, if I click on Assign Blogs I go here:

    dev.mydomain.com/tools/wp-admin/ms-admin.php?page=sites&action=assignblogs&id=1

    With this very simple message: "Invalid blog."

    Can someone help me out with this? Is there still a way to do this and I am just missing it?

    I've spent all day searching forums and codex. I read slow, and maybe my search terms are lacking, but I can't find anything about this. I apologize if this has already been covered and I just didn't see it. I would really appreciate a link to more info if that's the case.

    Thanks very much for taking the time to read. Any help offered will be very much appreciated.

    ~Snow

  2. You shouldn't need to 'move' anything, there's a domain nmapping plugin that can do all the hard work.

    http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/

  3. Snow
    Member
    Posted 4 years ago #

    I saw that plugin and found it very confusing, as did my partner. I will try again to sort out what it's for and how it might help me with this.

  4. It's a bit of a head trip :)

    Otto has a nice tutorial here: http://ottopress.com/2010/wordpress-3-0-multisite-domain-mapping-tutorial/

  5. Snow
    Member
    Posted 4 years ago #

    I think I may have blundered into the solution just before you posted that link. Thank you for the link, I will read that, and hope that it helps me understand better what's going on and why it works.

    I'll switch this thread to resolved if the solution holds while I shove at it to make sure it isn't going to come apart on me.

    Thanks very much!

  6. Snow
    Member
    Posted 4 years ago #

    Mostly that link confirmed what I had done, helped me fix one setting, and it did explain things a little better, so again, thank you.

    In my testing I have one remaining glitch I see. When I log out of the mapped site it sends me to the old login screen.

    (Examples not real links)
    1) tools.client.com (newly mapped, working)
    2) tools.client.com/wp-login.php (works fine)
    3) [log out]
    4) land here: dev.mydomain.com/tools/wp-login.php?loggedout=true

    On the Domain Mapping Configuration page, I have entered the IP address for the server, and only #2 (permanent redirect) under Domain Options is marked as yes.

    I had #3 (user domain mapping page) marked yes, went to the site, to Tools > Domain Mapping, and added the new primary domain. Then I went back and turned off option #3.

    Seems like a bug, since I haven't seen anything about it, in any of the docs of read. Before I go post it as a bug for the plugin, I thought I'd check and see if this is something you're familiar with.

    Thanks again for your help!

  7. It;s not a bug. The originating domain will always be there somehow.

    this is also part of the "remote login" option.

    this plugin works the same way the domain mapping feature on wordpress.com works.

  8. Snow
    Member
    Posted 4 years ago #

    Hi Andrea,

    I do understand that with this plugin the old domain is there underneath, but I don't want my client to see it or their customers. So, if the old domain shows up anywhere, that imo is a bug. If it's not a bug, and that's seen as acceptable, then this isn't my preferred way to fix this, in the long term, but if it's the only work-around to the problem, I'll use it for now. I have to refer back to my original post at this point, about the way it used to work to actually move a site to the location where I need it to be once I've completed development, and hope that the broken functions will be fixed soon.

    I'm afraid I don't follow you. How is this part of the "remote login" option? I have that turned off. Are you saying I should turn it on? Based on this description, that would make things worse: "Remote Login – This will make your login pages for all sites redirect to your main site to do the actual login. The benefit of this is that when you log in to one, you log into all of them. The downside is that the URL changes to another domain in order to log in." (This is from the 2nd page ipstenu linked to above.)

    What "domain mapping feature on wordpress.com" are you referring to? I'm not familiar with this. We host installations of WordPressMU on our own servers. I've never had a site hosted by wordpress.com.

    Thanks for your response. Unfortunately I'm more confused now.

    ~Snow

  9. What "domain mapping feature on wordpress.com" are you referring to? I'm not familiar with this.

    WordPress.com has a paid feature to upgrade for users to use their own domain name. that's what this plugin is based on.

    you're using MU. You are running your own version of wordpress.com for your own clients. Your users are paying YOU for this feature.

    there's a different domain mapping plugin that hides the originating domain entirely and has less options for confusion. it's over at wpebooks.com

  10. Snow
    Member
    Posted 4 years ago #

    Thanks Andrea, I will look into that.

Topic Closed

This topic has been closed to new replies.

About this Topic