Support » Fixing WordPress » moving a site from dev to production

  • ScottKR

    (@scottkr)



    I just moved a site from dev.sitedomain.com > sitedomain.com but some of the images are now missing.

    I did go into the Admin Settings>General and updated the WP Address and the Site Address.

    Some images are missing. HELP!

Viewing 15 replies - 1 through 15 (of 16 total)
  • WPyogi

    (@wpyogi)

    Forum Moderator

    See:

    http://codex.wordpress.org/Moving_WordPress

    Note that you may need to update the links/URLS…

    ScottKR

    (@scottkr)

    Already did the changes to the two URL’s in the Admin Settings.

    I found in the DB wp_options > option_name and all the info in there had dev.domain.com so I just removed the dev. but some of the images are still missing.

    Another good option isi backupbuddy

    ScottKR

    (@scottkr)

    I have a back up of the site on my local machine.

    Can you please help me in finding out why some of the images are missing? I’m using a custom template.

    WPyogi

    (@wpyogi)

    Forum Moderator

    Have you looked at the file paths for the missing images? Are they correct?

    ScottKR

    (@scottkr)

    and where do I find them?

    if Admin, where?

    If the DB where?

    WPyogi

    (@wpyogi)

    Forum Moderator

    Look at your site where they are missing. Use browser tools like Firebug.

    ScottKR

    (@scottkr)

    Ok so I see dev. in the image src paths. Where do I edit all the paths?

    WPyogi

    (@wpyogi)

    Forum Moderator

    I thought you went through the Moving WP article? It explains about “search and replace” in the database. Did you miss that?

    http://codex.wordpress.org/Moving_WordPress#When_Your_Domain_Name_or_URLs_Change

    Be sure to backup the database before messing with it :).

    ScottKR

    (@scottkr)

    I backup up the site and the DB and saved both to my local computer. Not that dumb LOL.

    WPyogi

    (@wpyogi)

    Forum Moderator

    I figured that you would be on top of that, but I’ve learned (not so happily) that I ALWAYS need to say that :). LOL!

    ScottKR

    (@scottkr)

    I read that article. What I missed in the article it says to change the URL’s in the Admin Settings before you moved it all. I did it after. But no matter, I feel because this site is highly custom, not your basic WP site, a lot of it done from scratch.

    ScottKR

    (@scottkr)

    I think there is still some stuff in the DB is still looking at paths with dev. in them. Is there a sql command I can run to search all tables and records for dev. and change it all?

    WPyogi

    (@wpyogi)

    Forum Moderator

    This plugin is supposed to be good:

    http://wordpress.org/plugins/velvet-blues-update-urls/

    ScottKR

    (@scottkr)

    Can’t use as it says
    Compatible up to: 3.5.2
    I’m using WP 3.6.1

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘moving a site from dev to production’ is closed to new replies.