WordPress.org

Support

Support » How-To and Troubleshooting » Moved WP directory and WP stopped working

Moved WP directory and WP stopped working

  • I accidently drug my “blog” directory in my website cPanel to a sub directory and immediately moved it back. Now my site won’t load. My error log includes this info:

    [01-Nov-2009 12:45:33] PHP Warning: require_once(/home/outahere/public_html/blog/wp-load.php) [<a href='function.require-once'>function.require-once</a>]: failed to open stream: No such file or directory in /home/outahere/public_html/blog/wp-blog-header.php on line 12
    [01-Nov-2009 12:45:33] PHP Fatal error: require_once() [<a href='function.require'>function.require</a>]: Failed opening required '/home/outahere/public_html/blog/wp-load.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/outahere/public_html/blog/wp-blog-header.php on line 12
    
    [31-Oct-2009 15:42:36] PHP Warning: require_once(../wp-load.php) [<a href='function.require-once'>function.require-once</a>]: failed to open stream: No such file or directory in /home/outahere/public_html/blog/wp-admin/admin.php on line 20
    [31-Oct-2009 15:42:36] PHP Fatal error: require_once() [<a href='function.require'>function.require</a>]: Failed opening required '../wp-load.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/outahere/public_html/blog/wp-admin/admin.php on line 20

    Thanks in advance for any help!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi,

    It seems that you have not copied all the files from here to there. so check all the files and make sure that they are completely copied.

    Thanks,

    Shane G.

    I double and triple checked this–it seems like all the files were copied back. And I also looked at the config file to see if anything was amiss. I don’t know what else to do as I immediately copied the entire directory back to where it was previously. It seems to be looking for a “wp-load.php” file which I can’t find anywhere.

    Thanks again, really hope I didn’t lose my entire blog. 🙁

    Moderator cubecolour

    @numeeja

    ɹoʇɐɹǝpoɯ

    Thanks again, really hope I didn’t lose my entire blog.

    Don’t worry as long as you have the contents of the wp-content intact, ie your theme & plugins, plus the wp-config.php, you can replace any missing files with new ones extracted from a fresh downloaded of the installation zip (ensure you download the same version as installed).

    For the record, this is probably a permissions issue. I had the exact same error and I chmoded my files to be owned by root and everything worked fine.

    chmod root wp-* -R

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Moved WP directory and WP stopped working’ is closed to new replies.
Skip to toolbar