WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Moved website to root. Get error 404 when insert images

[Resolved] Moved website to root. Get error 404 when insert images

  • Hi,
    I just moved my website from example.com/dev to example.com. I can update/create pages ok as long as there are no images in them.

    If I use the Upload/Insert facility to insert images and I click Update, then I get redirected to an error 404 page. I use the File Gallery plugin. Disabling that does not help. Even if I set the image src to an external image on a different website, I still cannot update and get the 404 msg.

    Any ideas please?

Viewing 3 replies - 1 through 3 (of 3 total)
  • esmi

    @esmi

    Forum Moderator

    Did you follow the instructions in Moving_WordPress?

    Yes I did – carefully as well. I found an error in logs:

    [Wed Oct 17 13:11:30 2012] [error] [client 183.234.12.46] ModSecurity: Access denied with code 406 (phase 2). Pattern match “(?:\\b(?:on(?:(?:mo(?:use(?:o(?:ver|ut)|down|move|up)|ve)|key(?:press|down|up)|c(?:hange|lick)|s(?:elec|ubmi)t|(?:un)?load|dragdrop|resize|focus|blur)\\b\\W*?=|abort\\b)|(?:l(?:owsrc\\b\\W*?\\b(?:(?:java|vb)script|shell)|ivescript)|(?:href|url)\\b\\W*?\\b(?:(?:j …” at ARGS:content. [file “/usr/local/apache/conf/modrules2/modsec2.user.conf”] [line “82”] [id “950004”] [msg “Cross-site Scripting (XSS) Attack. Matched signature <src=\\”http:>”] [severity “CRITICAL”] [hostname “www.example.com “] [uri “/wp-admin/post.php”] [unique_id “UA6gctXlfQAWEHn76QYAAu”

    Is this a possible MOD_Sec issue?

    I have fixed the issue. I contact the domain hosting company. It was a MOD security problem. In the end, the rules were bypassed which triggered for my domain.

    Thanks for your help.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Moved website to root. Get error 404 when insert images’ is closed to new replies.