Support » Installing WordPress » Moved to new server but get blank white page

  • I moved my WP site to a new server. I moved all files and the db over, made the necessary modifications to the wp-config file but I see a blank white page instead of the site when I try browsing the site.

    My url is

    What am I doing wrong? I know PHP is working because my test pages all work but anything related to WP is coming up blank.

Viewing 15 replies - 1 through 15 (of 19 total)
  • Are you sure the dns has resolved? Frequently wp will just not work properly until the dns is solid; this is also the problem with trying to run wp on a subdomain.

    if i type a nonsense uri, I don’t even get a 404. i would second the opinion that your dns might need to settle.

    this works >

    this doesn’t >

    I suppose you could have an issue with your wordpress file uploads. You could try uploading them again. Better is to uncompress them right on the server. do you have shell access?

    It didn’t do this the last time I changed servers, but I’ll wait a day or so and see what happens.

    Manstraw: Yes I do, and that’s what I did 🙂

    hmm, next day for me, and it’s still not coming up.

    make a file called phpinfo.php and put this in it

    echo phpinfo;

    visiting should provide a page of php config values and such. can you see that page properly?

    manstraw: That’s what puzzles me. Only WP related php files are coming up blank. I can get any other php file I create to show up. I did the phpinfo function in test.php yesterday:

    well, I’m starting to think there’s another problem. I recommend you reinstall all the files from scratch.

    I sometimes use to see what happens in the response to a http request. It’s giving me this error “HTTP header termination string not found”.

    If your database wasn’t available, you’d get a response for that. So that makes me think it’s in the files, or perhaps rewrite rules. Do you have permalinks on? Check for .htaccess files that might already be on your server. Perhaps there is a conflict.

    I tried a fresh install 🙁

    Check your /index.php file (should contain a reference to “Short and sweet”).

    Should be at

    Contents of index.php:

    /* Short and sweet */
    define(‘WP_USE_THEMES’, true);

    is your PHP error reporting turned on? Every time I’ve ever seen this problem is only when PHP erro reporting is turned off, and there’s an error in the script somewhere. If it’s turned on, then you’d see the typical error message – with the line number and exactly what the problem is.

    Just a thought 🙂

    When I try I get a download handler (the dl’ed index.php is blank). When I try I get a blank page. Either way – check with your host…

    I was having the same issue, all wp pages were whitescreen. I then re-installed using and had no issues at all. I suggest trying the zip over the tar.gz.

    Well, one simply question… when you move to the new server, the db you edit the url for the new domain? Or it’s the same?

    doodlebee: yes error reporting is on.

    Yosemite: i’m having them look into it.

    kinshay: already tried

    gutielua: the domain is the same, the only difference was the db name which was edited in the config file.

    The following error was encountered:
    Zero Sized Reply

    Why did you try delete some plugins, something similar happend to me on my test blog on

    The both servers has the same version of PHP or config topics?

    Here still your blog on google cache:

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Moved to new server but get blank white page’ is closed to new replies.