Support » Plugin: Amazon Link » Moved to new host, plugin causing 403 errors

  • We recently shifted host to Krystal. All seemed fine until I went to publish a post when I got a 403 error. By the usual old method of disabling plug-ins and re-enabling one by one, the culprit turned out to be this one (bizarrely!).

    When it is enabled, I can’t post or save a draft. I’ve tried uninstalling the plug-in completely and then re-installing with no luck.

    Anyone else encountered this? It would be a shame to ditch it.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author paulstuttard

    (@paulstuttard)

    Hi,

    Very strange, the plugin normally does not do anything when a post is saved. It might be an odd interaction with another plugin?

    Do you know if there is any more details of the error (can you see the error in the server logs?).

    Do you just have the plain amazon link plugin installed, no ‘amazon link extra’ plugins installed?

    A bit stumped, to be honest!

    Paul

    It is weird as we simply copied the filesystem as is from one server to another. Permissions are all the same, plugins the same… It’s definitely not clashing with another plugin as I enabled them only one at a time until I hit the one that was the cause.

    Definitely befuddling! I’ll check server logs if I can find them (new system so everything has moved) and see if I can spot anything.

    And, yes, plain vanilla plug-in.

    Iain

    Checked the logs and nothing sticks out, I’m afraid.

    Plugin Author paulstuttard

    (@paulstuttard)

    Thanks for checking,

    Do you know, if you update/create a new post and you get the 403, has the change you made actually taken affect (i.e. is the new post visible on the site).

    i.e. Is it failing to update the post. Or is it failing after the update and simply not displaying the edit screen again?

    Another thing to check is on the Edit Post screen in the Add Amazon Link box, can you do a simple product search? Do you get any results back?

    Finally do you know what version of PHP you are using?

    Paul

    Thanks for getting back to me, Paul – appreciated. I’ve checked each of your points:

    1) A mixture! If I create a new post and name it, then click “Save” (e.g. draft) then the post is created and the title saved and the 403 displayed… but that’s it. No content, images, category, etc. If I click Publish, I get the 403, but the post is *not* published. I would say that falls under “failing to update the post”.

    2) Did a quick product search (Author name Gibson) and it works fine.

    3) PHP 5.6.33

    Iain

    Plugin Author paulstuttard

    (@paulstuttard)

    Ok, thanks,

    I’ll dig a bit deeper.

    Paul

    Plugin Author paulstuttard

    (@paulstuttard)

    Are you hosting at krystal.co.uk?

    I created the most basic account and set up a WordPress install, installed Amazon Link, and I’m not having any problems (yet).

    However this is from my work, which is firewalling all the javascript and css, so it could be something to do with that?

    I’ve tried enabling the following options which add various hooks and callbacks into WordPress and trigger different levels of functionality:
    * Enable the Cache
    * Enable localisation and install ip2nation DB
    * Enable Media Library
    * Enable User Associate IDs
    * Add Associate Channel

    You could try disabling some of these to see if it helps?

    Paul

    Yes, just moved to Krystla over the weekend.

    I’ll try tinkering when I get home (much) later tonight. I also suffer from my work filtering things out! Including access to my host’s control panel 🙁

    Again – thank you.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Moved to new host, plugin causing 403 errors’ is closed to new replies.