WordPress.org

Support

Support » Multisite » [Resolved] moved servers and broken navigation

[Resolved] moved servers and broken navigation

  • Hey all thanks in advance for time and suggestions!

    step 1: I moved database to another box. all is good and site works great.

    step 2: I need to move wordpress and all the files to another instance of linux I am using, not the same server as the database. I was able to install all the LAMP stack on my new instance, move the entire wordpress install I was using on old server to new one(including .htaccess, wp-content etc). made sure mode_rewrite is install, changed the AllowOverride to All in the sites-available file. the site comes up but does not allow me to navigate to anything (404). Some plugin’s seem broken too, but I am guessing if I get this navigation thing worked out they might work. All the domain names are mapped the same as well and seem to work its just the pages and post that don’t. I use pretty permalinks, but it doesn’t work using default settings either.

    again thanks for your help.

Viewing 15 replies - 1 through 15 (of 29 total)
  • You should have updated your wp-config to point to the DB location, since it won’t be localhost anymore.

    the database part worked fine (that was step 1), and my new server that is now hosting my multisite wordpress site talkes to the database correctly, but I am unable to navigate to the pages and posts.

    I have to be pedantic because you’ve never once mentioned your wp-config.php file 🙂

    You did edit that right? Saying ‘I moved the DB’ just means you moved the DB. I can’t magically see what else you did (rumors of my psychic powers aside) so I gotta nag and ask.

    And did you also bring your .htaccess over?

    aside from being magical, in my orginal post I did say that I move my entire old wordpress install including .htaccess. However i did not mention my wp-config you are right but I moved that too, and all other files from my install. I will spread more rumors of you powers on twitter.

    When one file’s not mentioned, we doubt everything 😉

    Try re-saving your permalinks on your main site, see if that magically works?

    No magic for me today Mika, saved the permalinks but the problems persists.

    Well. Okay, roll up your sleeves.

    Can you post the content of your .htaccess?

    Interesting stuff, I got rid of the wptotal cache stuff and changed my .htaccess to look like the following

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress

    top level site now works but subsites dont work still.

    What’s happening on the subsites? 404s?

    yes 404’s

    just adding a guess but did u check in your config file and updated
    define( ‘DOMAIN_CURRENT_SITE’, ” );
    define( ‘PATH_CURRENT_SITE’, ” );

    them to point to your new domain

    Rob, have you turned off all your plugins? You mentioned the caching plugins, make sure those are off, and not just removed the htaccess stuff.

    sorry got busy, plugins are off. still 404’n

    When you moved sevrers, did the domain name change?

    no name changes

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘[Resolved] moved servers and broken navigation’ is closed to new replies.
Skip to toolbar