Support » Fixing WordPress » Moved Server and Database and Now the Blog doesn’t Exist?

  • Resolved PetLvr


    I’ve started a new thread because my problem shifted from its original problem to my current problem..

    Reader’s Digest Version:

    I moved to a new host provider. There was issues because of the Mysql engine supported. The previous thread helped me restore the database and documents what I did. Besides the InnoDB vs MyISAM differences … there was also this issue – in the wp-config.php file..


    define('DB_NAME', 'newmoon'); // The name of the database
    define('DB_USER', 'petlvr'); // Your MySQL username


    define('DB_NAME', 'newmoon_newmoon'); // The name of the database
    define('DB_USER', 'newmoon_petlvr'); // Your MySQL username

    The newmoon_ prefix is the name of the domain login. For the actual tables, it was unchanged from the old to the new database …

    $table_prefix = 'moon_'; // example: 'wp_' or 'b2' or 'mylogin_'

    I went into the new database with myphpadmin and fixed the siteurl in the moon_options table.

    The URL/domain is

    This is the new problem. The site is moved, the files copied over, the database recreated .. but when you go to the above site – it wants to INSTALL wordpress and doesn’t recognize anything. After my first install, I always rename the install.php to something else, so I there’s not been any risk of clicking it.

    I would like to know what I can do to get my site working. There is only about 5-10 posts I think in this one. It’s a prelude ‘practice’ for moving a much larger site and while I can risk the downtime on this blog, I can’t risk downtime moving any other blogs, like my blog ..

    Any suggestions? What will happen if you reinstall a wordpress blog on a database that already exists? Why doesn’t my wp-config work?

    Thanks in advance


Viewing 10 replies - 1 through 10 (of 10 total)
  • I’d say it’s a problem with the moon_ table prefix because anything else would result in a connection error.
    If checking that gets nowhere, do you want em to take a look ? It seems you’ve been through the mill a bit getting things sorted and sometimes a fresh pair of eyes helps ?
    If you do, drop me an email – I’ll need access to your site so I can check files though.
    tamba2 @ gmail . com

    Hi podz … I thank you for your offer and have sent you the access information .. I REALLY appreciate this! // HART

    I’d like to thank podz for FIXING my blog! THANK-YOU!

    This is what basically was the problem. In my other host provider, I created a database, and created a user. That was it. In the new host provider, I created a database, created a user and then had to give permissions to the user. I knew this – because I received particular errors about this issue early on.

    So – in the setup phase on my host in the cPanel, the line was ..
    Permissions: [box1] All [box2] Alter [box3] etc etc etc…

    I must have ticked the box2 (after “All” but meant for “Alter”) and didn’t have the correct permissions for the user. It’s almost coming back to me now – that’s probably what I did.

    When I gave podz access to my database, he figured this out – fixed my error, and now the blog is up and running. If that wasn’t enough, he even offered to set up periodic backups which is a VERY useful thing to have.

    You are my HERO podz 😀

    I hope this bit of info helps others that might be stuck like I was. Happy New Year Everybody!


    I followed this from the original thread because I was trying to find out which db would be better for me to setup my sql with but anyway, congrats Hart.

    I didn’t even know podz was from that tamba site, good info P, I visit that site quite often, actually tried commenting on it earlier today but couldn’t find out where. No matter, I just got back from the bookstore 🙂 G/L.


    I have the same problem, same kind of move, and get the install screen.


    define(‘DB_NAME’, ‘hanna_dax’); // The name of the database
    define(‘DB_USER’, ‘hanna_dax’); // Your MySQL username


    define(‘DB_NAME’, ‘tobi_dax’); // The name of the database
    define(‘DB_USER’, ‘tobi_dax’); // Your MySQL username

    The config is adjusted, all files have been transmitted and I can’t get the db import to work. Have to say, it’s PHPMyadmin 2.9X and the old way described in the restore help file in codex seems to not be available anymore. With import I see all the tables right there, I adjust the URLs but get old line of no WP installed.

    What should I try else?

    BTW – same host, different domain (for now)

    It looks like the original problem was fixed by setting the proper $table_prefix in wp-config.php. Have you confirmed that it is the same value?

    Hi again,

    yes, all settings and data of the non-DB part of WP including the config are properly set for the new dbase and the new host.

    Also, the user of the DB has full rights to the DB, so that’s not the problem here either.

    I adjusted – via PHPMyadmin – the URLs to the new URLs, too.

    Still I get the “install WP” thingie.

    Hi again,

    my bad – I overlooked a superfluous backtick :-}

    Everything’s there and working just peachy… so far 😉

    Ah well – not so peachy, all the UTF-8 chars are gone, anyone know a solution to that?

    It is more proper for you to start another thread with that question.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Moved Server and Database and Now the Blog doesn’t Exist?’ is closed to new replies.