WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Moved my WordPress site to a new host

[Resolved] Moved my WordPress site to a new host

  • I recently moved my website to a new host
    I lost a few photos on a few pages but thought the site was fine
    Went and signed into the dashboard and found all these errors

    Deprecated: Assigning the return value of new by reference is deprecated in /home/kingid5/public_html/wp-includes/class-simplepie.php on line 739

    Deprecated: Assigning the return value of new by reference is deprecated in /home/kingid5/public_html/wp-includes/class-simplepie.php on line 1109

    Deprecated: Assigning the return value of new by reference is deprecated in /home/kingid5/public_html/wp-includes/class-simplepie.php on line 1603

    Deprecated: Assigning the return value of new by reference is deprecated in /home/kingid5/public_html/wp-includes/class-simplepie.php on line 1644

    Deprecated: Assigning the return value of new by reference is deprecated in /home/kingid5/public_html/wp-includes/class-simplepie.php on line 1664

    Deprecated: Assigning the return value of new by reference is deprecated in /home/kingid5/public_html/wp-includes/class-simplepie.php on line 1694

    Deprecated: Assigning the return value of new by reference is deprecated in /home/kingid5/public_html/wp-includes/class-simplepie.php on line 1764

    hundreds of them just different line numbers

    If anyone could help that would be truely appreciated!!!!!

Viewing 8 replies - 1 through 8 (of 8 total)
  • I turned off all plugins and its still same thing?

    Clayton James
    Participant

    @claytonjames

    You may be able to suppress the warnings. Take a look in your wp-config file and see if debugging is turned on. If it is, turn it off and see if that takes care of the warnings.

    define(‘WP_DEBUG’, false);

    Yes its on false

    I was wondering if it could have to do
    that my new host has my file path

    home/kingid5/public_html

    it was

    home/kingidea/public_html

    They tell me they can’t change it

    Thanks for trying ClaytonJames

    Clayton James
    Participant

    @claytonjames

    Just thinking out loud here, but you you might contact your hosts support group again and ask them if they allow the use of custom php.ini files in your account. If so, ask them what you might need to do just to suppress the (deprecated) php warnings on your site.

    Christine Rondeau
    Volunteer Forum Moderator

    @crondeau

    I would try re-installing the a fresh copy of the wp-includes, wp-admin folders and root files again (don’t delete your wp-config.php though)
    I’m thinking that there are some that might not have migrated during the move.

    Thanks Christine I moved the folders again same thing
    I guess that my site is older theme that the changes in the PHP from 5.2 to 5.3 made some deprecated errors?
    But thankfully my new host inmotion hosting has been very good to me during the process and they are much faster then my old host can’t wait tilll its fixed and enjoy the fast upload of pages.
    It has not effected my frontend much but I noticed a little hanging.
    I was looking for my debug log or error log but I guess its not turned on.

    Is there a way to tune a site or a plugin after I get my site up?

    Kingidea.com

    Thanks for all the help my host fixed it all!
    Now to just replace all the missing photos!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Moved my WordPress site to a new host’ is closed to new replies.