Support » Networking WordPress » Moved Multisite Install, Not Working

  • I have a strange problem. We’re moving our site to a new server. A portion of our site is a multisite install of WordPress in the directory. So far I have…

    – Copied all multisite files to the new server
    – Exported database on old server, imported into new database file on new server
    – Changed wp-config.php to match new server settings

    I’m using Gas Mask for Mac to modify my hosts file and access the site on the new server while keeping the same url settings. I’m able to access, which has a regular single install of WordPress; but when I try to access my browser downloads a file, and I get a blank screen. For example, if I go to, my browser actually downloads wp-login.php vs loading the page.

    Any ideas why this is happening?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Sounds like PHP isn’t installed correctly on the new server.

    For grins and giggles, though, rename the plugins folder to ‘old-plugins’ (ditto mu-plugins -> old-mu-plugins)

    Thanks Ipstenu. Plugin trick didn’t help. We have a single install of WordPress in the root of the new server, and it’s working fine. Wouldn’t that indicate that PHP is installed correctly?

    It should. That’s really weird. I’ve only see the php downloading when the file just is NOT being seen as a php file by the server.

    Make a phpinfo page called test.php in the location. See what happens to THAT. If it downloads, it’s your server setup.


    Tried test.php in the multisite directory, and it downloaded instead of running. Then i moved test.php into the root and it ran normally.

    It appears PHP is not working only in the multisite directory… strange.

    If there’s a .htaccess file in the multisite folder, rename that to old.htaccess for starters.

    But. Check your httpd.conf file and … yeah, that sucks 🙁

    Tried the .htaccess file before with no luck. I looked in the etc directory for httpd.conf, but it wasn’t there. Is that were it should be, and what should I be looking for in the file?

    It’s a server file, and mine is in /etc/httpd/

    In there should be a call to PHP. All I can guess is that yours is only specifying one folder location? I’ve never seen it work in a main folder but not a subfolder.

    I have. 🙂

    @raid contact your webhost support, get them to kick the server & fix it.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Moved Multisite Install, Not Working’ is closed to new replies.