Support » Fixing WordPress » moved host and broke site

  • Resolved tqfan

    (@tqfan)


    Hello

    I am rather confused and hoping someone can help.

    I had my website working fine until i decided to move host (clearly a fail)…

    I followed instructions, created mysql database and so on, and i then tried to upload my site via filezilla, but i kept getting time out errors. i use a macbook and imac, both were timing out. so i got a windows laptop and installed filezilla and was able to upload my site files. (i am assuming the first issue of time outs was a previous version of filezilla, since my macs OSX are not supported for newer filezilla versions).

    so i was in contact with my host as well. they said they allowed my IP on the server firewall at their end, so this could be why the windows upload worked, who knows.

    so i got everything uploaded but nothing worked. i just kept getting an error that the site would not load.

    i contacted my host and they said the following:
    We updated your WordPress from our end, and now your site is working fine to confirm follow below URL.
    =================================
    http://otterlycreative.com/wp-admin/install.php
    ==================================
    Just fill up the needed information and your site will start working fine.

    so i did query why i needed to install when i had already uploaded all my WP site files (?). they said it would work. so i did the install.

    my site is there, i can see it, plugins are there, themes are there, but none of my customisation, none of the pages i created, none of the photos i had uploaded.
    i can still see them on the server via filezilla.

    so i don’t know what’s gone wrong or what i need to do to fix it.

    can anyone help me?!

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Thread Starter tqfan

    (@tqfan)

    just realised i’ve posted this in the wrong forum, was meant to be fixing wordpress, thought i was in the right place *sigh* sorry.

    You’re fine here as far as I know.

    You need to move your theme(s) and plugin(s) over then migrate your database over. The database is ‘where all the good stuff exists’.

    Thread Starter tqfan

    (@tqfan)

    the themes and plugins are all over as well. the problem lies with the database.

    i get this error:

    SQL query:

    — Database: otterlycreative

    CREATE DATABASE IF NOT EXISTS otterlycreative DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci
    MySQL said: Documentation

    #1044 – Access denied for user ‘cpses_ot3kvklf6y’@’localhost’ to database ‘otterlycreative’

    i’m not sure what it means, i don’t know what that user is??

    i never had problems when i moved another WP site, so this one has thrown me, especially when i don’t know too much about what the above means.

    thanks.

    Dion

    (@diondesigns)

    You must log into your hosting control panel (probably cPanel), go to its MySQL section, and give the user cpses_ot3kvklf6y access to your database otterlycreative. If you are unsure how to do this, please contact your hosting company.

    Thread Starter tqfan

    (@tqfan)

    no, i can do that. i thought i would have to do that, i’m just very confused as to where this username has come from, lol!!

    will do that now, thanks.

    Thread Starter tqfan

    (@tqfan)

    now i am getting the same error but with a different user!

    #1044 – Access denied for user ‘cpses_otmo19txun’@’localhost’ to database ‘otterlycreative’

    so added that user… but still getting the error…

    Dion

    (@diondesigns)

    What DB user is listed in your wp-config.php file?

    But before you go too far, if you have “managed WordPress” hosting, you should contact your hosting company and specifically ask whether it is possible to use your own custom database. Many plans of this type require databases and DB users created by the hosting server, which I suspect is why your hosting company set up WordPress from scratch for you.

    Thread Starter tqfan

    (@tqfan)

    yes, it is possible to use a custom database. i have moved a WP site to this host before. i will double-check with them.
    they didn’t set it up, they said they updated it for me.

    the DB user in wp-config file is otterlyc_otterlyadmin this is the one i created during the migration.

    Dion

    (@diondesigns)

    Your rogue DB users are not in WordPress, they are users created by cPanel for accessing phpMyAdmin. You should contact your host, or perhaps submit a support ticket through cPanel.

    Thread Starter tqfan

    (@tqfan)

    yes they are created by cPanel just not sure why they don’t work!! i have asked host if they will try to do it for me. I’ve been back and forward with them for a wee while now, they sometimes don’t seem to know what i’m saying to them, but they are helpful otherwise.

    thank you

    Thread Starter tqfan

    (@tqfan)

    just an update, my host eventually helped in the end, there was an issue with the database and what i was doing from instructions found, was not helping. so they did it (by the looks of it, the same thing i couldn’t, lol) and it’s all working now.

    thanks.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘moved host and broke site’ is closed to new replies.