Support » Installing WordPress » Moved from MAMP to live, can't see database data

  • Resolved Sherah


    Hello, I’m having issues uploading a WordPress installation onto a site after fully developing it locally on MAMP.

    Once I was finished developing the site locally, I made backups of the local WordPress folder and the database. I copied the contents of the local WordPress folder into the root folder of the site I want to go live. I edited the live wp-config file to point to a new database I created at the host (which, by the way, is GoDaddy).

    I exported the contents of the local database into a SQL file, then imported that file into the new database connected with the live site. No problems; everything looks fine here. All the tables and data are here.

    When I go to the main site to activate the new WordPress installation, it looks ok at first. All of my plugins and themes are where I would expect them to be (those come from the WordPress install, not the database). But when I go in to look at my posts, there are 61 posts in the admin panel for posts, but each entry is blank – no titles, no data. It’s like the database is being accessed – it can see the rows of my tables maybe – but the actual data inside isn’t being retrieved for some reason.

    None of the categories or tags are showing up, and even more worrisome, I can’t even GO to the “Pages” admin page. When I click on “Pages,” I see a blank page with this error:

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.
    Apache Server at Port 80

    ~ I have tried re-installing several (6-7!) times with the local copy of WordPress I’m using.
    ~ I have tried using a freshly downloaded, clean copy of WordPress and then just importing the data from an export from my local copy, thinking to just re-do things. My importing tool does not work properly; it either doesn’t work at all, giving me “file does not exist” error messages about an xml file that definitely exists AND can be successfully imported on another test blog, or in some cases it “imports” the file but only one post shows up, and not all the Pages.
    ~ I have created another database on the new site. Same problem.
    ~ My database is not large, nor is my import. Non-compressed it’s 1.7MB. The import xml file is only 261 kb. The files are not corrupted – WordPress is not seeing them correctly.

    I have tried many other things but don’t want to overload this question. The essence of the problem is that my particular combination of GoDaddy hosted site + WordPress 3.4.2 + databases is not working together in harmony.

    Has anyone heard of this problem before? Is it GoDaddy? I’ve read a billion help files and forum discussions on all these problems and the only thing I can think of is that it could be something on their end that I don’t have control over or know about.


Viewing 4 replies - 1 through 4 (of 4 total)
  • ahuggins


    Have you updated the two options for your site url in the wp_options table? (if you changed your DB prefix it could be YOURPREFIX_options)

    It might be option_id 1 and option_id 37 should be siteurl and home in the option_name fields.

    It’s just a guess but you didn’t mention that in your post and I know you have to update those when you move from a localhost to a live site.



    Thank you for responding, yes I have updated those options to reflect the correct paths. Just to make sure (even though I’ve checked and checked it), I looked just now again and yep, correct paths. Sigh!



    Ok, I resolved this issue, sort of. What I did was, to test my theory that it’s GoDaddy’s fault, I ran the install on a domain I own at Dreamhost. I then of course created a new database and imported the exact same SQL file into this new database.

    When I configured everything (exactly the same!), it worked the very first time with no problems!

    I called GoDaddy and they didn’t know what the issue was. So that part remains unresolved. But for my purposes, this is a host issue. Transferring my client’s site to Dreamhost, who has always been great for me.



    closing this topic.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Moved from MAMP to live, can't see database data’ is closed to new replies.