WordPress.org

Support

Support » Installation » [Resolved] Moved, but empty!

[Resolved] Moved, but empty!

  • I’ve used Skippy’s WPDB backup plugin and backed up my old blog, no problem.

    Then, I proceeded to follow the “Moving WordPress to a New Server with Fantastico” section in the Moving_Wordpress codex and podz guide on restoring the database.

    So I dropped all the tables in in my beta blog (in phpMyAdmin), then uploaded the SQL of my old blog- it was successful.

    But, now i only see two tables: wp_categories and wp_comments

    None of my posts made the move!
    You can see what happened here:
    http://www.addonelam.net/blog/

    The WP versions of both blogs are the same (2.0.2)
    I’m a newbie, btw.

Viewing 6 replies - 1 through 6 (of 6 total)
  • If you only see two tables, try to restore again. There should be a handful more.

    Restore using the same SQL file?

    I was looking again at the SQL just now, and..I don’t know if this is significant or not, but i notice that there are only two tables mentioned in the file! And one seems to be unfinished?

    For the wp_catergories table, it ends like
    #<br />
    # End of data contents of table
    wp_categories<br />

    But for the wp_comments table, there is none?
    Or rather, there is no conclusion like that for this file?

    After the long list of comments, there’s nothing else.

    Is there also supposed to be wp_posts and other tables in this backup file?

    If so, what happened while the plugin was “backing up the entire database”?

    I’ve done something!..but still not enough.

    I’ve gone into my SK2 section of the old blog, and deleted all the spam comments in there, before backing up again.

    Now, I have ALMOST everything. You see, I have 497 posts…the plugin only backed up 100!

    So, now Im seeing if my host’s backup grabbed all 497 posts…

    …and it worked!

    Sorry for the constant barrage of messages!

    If someone ever experiences same troubles I had..here are some tips:

    1) Empty the spam comments caught by SK2
    2) Have your host (or if you have access to phpMyAdmin) make a backup of your database (The plugin was limited for me).
    3) Follow everything the Codex says, after doing the above 2 : )

    Cheers!

    Sweet! Glad to see you got it sorted out.

    Thanks for following up with the tips for the next folks.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] Moved, but empty!’ is closed to new replies.
Skip to toolbar