[resolved] Moved blog to root directory, archives stopped working (5 posts)

  1. kendravanc
    Posted 6 years ago #

    Hello! I moved my blog to the root directory, and when I did, my (calendar) archives stopped working.

    My site is: http://www.demodecouture.com/

    I followed the instructions about giving wordpress its own directory while leaving the blog in the root: http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    I'm guessing it's a problem with the Permalinks/.htaccess file, since I don't understand that last bit of the instructions -- I'm using /%category%/%postname%/ as my Permalinks setting, and I'm not sure what I need to change there.

    Everything else is working fine since the change.

    Any advice would be much appreciated! WordPress is pushing the limits of my HTML/CSS knowledge.

  2. esmi
    Forum Moderator
    Posted 6 years ago #

    Try resetting your permalinks to the default setting, saving the changes, resetting your custom structure back up again and saving changes again.

  3. Adam Harley (Kawauso)
    Posted 6 years ago #

    Do you have directories in your root directory structured by year and month as well? WordPress is set up to give priority to any existing files and directories with a given URL rather than trying to handle it itself.

  4. kendravanc
    Posted 6 years ago #

    Esmi - tried it, didn't work -- but thanks for the suggestion!

    Kawauso -- excellent idea. I do have my old archives from Blogger sitting in my root directory! I'll try removing them and see if that helps.

  5. kendravanc
    Posted 6 years ago #

    Kawauso -- that was it! I deleted all my old (year/month) Blogger archive files, and it's working perfectly now. Thanks so much for your help!

Topic Closed

This topic has been closed to new replies.

About this Topic