Support » Fixing WordPress » Moved blog to new host – no full posts showing

Viewing 3 replies - 1 through 3 (of 3 total)
  • rocke

    (@shashibhushan)

    My blog works, but is missing the CSS style. Or when I click any links, I am taken to my old site.

    This is due to WordPress storing your domain name as a piece of data in its database. Here is the way to fix the problem.

    1. Go to yourblog.com/wp-admin/ and login.
    2. In the left hand menu, click Settings.
    3. Click General.
    4. Next to WordPress address (URL), enter the correct domain and path.
    5. Next to Blog address (URL), enter the correct domain and path (usually the exact same).
    6. Scroll all the way down and click the Save Changes button.
    7. Return to your blog; it is fixed!

    I cannot get to myblog.com/wp-admin/ and login.

    This is more technical, but works every time.

    1. Login to cPanel and click the phpMyAdmin icon.
    2. In the left hand menu, click the database name corresponding with your WordPress installation.
    3. In the same left hand menu, click the wp_options table name.
    4. Click the Browse tab in the top left corner.
    5. Look for the row with option_id = 2 and option_name = siteurl. Click the pencil icon in this row.
    6. Replace the existing URL with the correct domain and path. Click the Go button.
    7. Go to page 2 of the rows where you find option_id = 39 and option_name = home. Click the pencil icon in this row.
    8. Replace the existing URL with the correct domain and path. Click the Go button.
    9. Return to your blog; it is fixed!

    Hope this will help U 🙂

    Regds
    Shashibhushan

    I had this exact problem when I moved my site to a new host last week. Index page was perfect, everything else was a 404 even though the data was all there.

    I fixed it by ‘refreshing’ the permalinks. Just go to the permalinks settings page, make sure it’s the setting you want, and hit save, and everything should work again.

    I can’t explain why it worked because I’m not that intimate with the nitty gritty of WordPress.

    alambertj –

    It worked! You are AWESOME!! You saved the little sanity I had left. Thank you!! Now I can go to bed worry free.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Moved blog to new host – no full posts showing’ is closed to new replies.