Moved blog to another location on the SAME server (12 posts)

  1. Jennifer420
    Posted 5 years ago #

    Hey all,

    Well, I've been helping someone move their blog from a subdomain of their website, to the root directory ...

    However, we can't seem to login and naturally, things are looking a little messed up - it doesn't seem to be calling the stylesheet either.

    Any idea how I can actually fix this? Please note that I have not done the change myself, as the client has the only ftp access. :|

    Thank you.

  2. Jennifer420
    Posted 5 years ago #

    Anyone ... please?! Lol Likely simple, but I'm missing it

  3. ClaytonJames
    Posted 5 years ago #

    Did they forget to change the blog URL's (remove the sub-directory from the path) in the dashboard prior to the move? You will have to remove the sub-directory from the addresses directly from the database.


  4. ClaytonJames
    Posted 5 years ago #

  5. Jennifer420
    Posted 5 years ago #

    Ok, so ... grrr

    I'm still at this:

    I've given all this a try and have done my best to follow it to a T, but still it's a no go :( My client is driving me crazy, though understandably so - she'd like her website accessible.

    Is there another way i could go about this? Aside from the URLs being changed, I don't think anything else has been touched.

    So ... what I was to reupload the files into the directory they were in, edit the URLs via the database again to the old location and try this: http://www.webdesignforidiots.net/2009/02/moving-wordpress-to-you-root/

    Would that work?

    Or is there another solution I'm missing?

    The website is currently all broken up and I cannot login.

    Also, something else I find odd, if you go the login page - the blog URL goes to WordPress!

    Thank you


  6. Jennifer420
    Posted 5 years ago #

    Does anyone thin that'll work? Please!

  7. I had to do this - search and replace URLs in the databse - a few days ago and it worked fine with a site that was improperly moved on the same server. But be careful and be familiar with PHPMyAdmin: http://codex.wordpress.org/Changing_The_Site_URL#Domain_Name_Change

    I also found I had to zero out the permalinks settings in wp_options to bring the site back up.

  8. Jennifer420
    Posted 5 years ago #


    Think I've made this much worse!

    I've been trying to move this blog to the root directory. The client was given directions on how to do this, but it only messed up. I've no idea (nor do they) what step the skipped/did incorrectly, etc.

    This is on a godaddy server by the way, I only hope I've tried moving it correctly myself as there are so many folders and such and all under a different 'main' domain name.

    Error is now:

    Not Found
    The requested URL / was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    I've followed both this: http://wpbloghost.tv/how-to-move-your-wordpress-blog-from-a-subdirectroy-to-root/ and this: http://codex.wordpress.org/Changing_The_Site_URL

    and now we're seeing this: http://justinverrengia.com/.

    I've backed up the database, should I just delete everything and re-do or ...

    What I can't understand is how it says nothing is there!

    Anyone know if there's something I'm missing do it being godaddy and the way things are located?

    Please let me know if you can offer any additional direction, I'd really appreciate it. :(


  9. kradio
    Posted 5 years ago #

    first off, move the entire wordpress install to the previous directory.

    second, open your wordpress admin, go to the settings-->general page.
    open your ftp client.
    in the general settings, change your wordpress address to the new location, and change your blog address to the new location.
    Now in your ftp client, move the entire wordpress install to the new location.

    That's how I've done it before, I would think it would work for others too.

  10. Jennifer420
    Posted 5 years ago #

    Thanks kradio,

    I've just tried that - but still getting this error:

    You don't have permission to access / on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

    I'm about ready to give up, I just don't know what else to do.

    Anyone familiar enough with this to fix for a fee?

  11. Delete your root .htaccess file. Be sure there's an index.php in root.

  12. kradio
    Posted 5 years ago #

    The forbidden thing, what you need to do is change the folder's permissions (this includes all of the wordpress folders and files too).

    I don't know what ftp client you're using, but I use FileZilla, and what you do in it is you select all the files on your server, right-click and choose "set permissions", you than need to change it to 775, which gives everyone the ability to see it and execute it (the ability to not do that caused the 403 error), and it gives you the ability to edit them, and wordpress the ability to edit them.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.