The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

[resolved] moved blog - permalinks broken (6 posts)

  1. wrboyce
    Posted 10 years ago #

    Hello to all!

    I've recently moved my blog from http://srv1.willboyce.com/blog.willboyce.com to http://blog.willboyce.com. The blog is still located on the same server so I simply copied the contents of /home/xx/srv1.willboyce.com/html/blog.willboyce.com/ to /home/xx/blog.willboyce.com/html/, logged in via srv1/blog changed the options for site_url etc, then re-logged in via blog.willboyce.com and regenerated my .htaccess (which worked fine).

    Now when I attempt to follow any link that uses mod_rewrite i get an apache error 404 and produces the following error in my error.log

    [Sun Jun 04 01:41:53 2006] [error] [client w.x.y.z] File does not exist: /home/xx/blog.willboyce.com/html/2006, referer: http://blog.willboyce.com/

    I've had a good poke around and read of the forums and don't appear to be able to find any documentation in regards to my issue so any and all help will be greatly appreciated.

    Kind Regards, Will Boyce

  2. fht
    Posted 10 years ago #

    Seems you finally managed it!

    Would you please point out what your problem was as I also want to move two friends blogs to another server.


  3. moshu
    Posted 10 years ago #

    for moving WP see the Codex:

  4. wrboyce
    Posted 10 years ago #

    Sorry, I shuold've said - I used to use the "/%year%/%monthnum%/%day%/%postname%/" permalink structure, but it no longer works, hence using the ?p=X nonsense ;)

    I followed the instructions in Moving_WordPress but I don't see how my error could be related to wordpress either? It seems as though apache isn't processing the redirect to me?

  5. wrboyce
    Posted 10 years ago #

    Just had an idea.. I changed my .htaccess to contain

    AuthUserFile /home/xx/blog.willboyce.com/html/.htpasswd
    AuthGroupFile /dev/null
    AuthName "Is Apache Processing .htaccess?"
    AuthType Basic

    <Limit GET POST>
    require valid-user

    made .htpasswd and tried to access my blog... I was not asked for a password and there was nothing extra written to error.log... my guess would be apache is ignoring my .htaccess files? Any ideas why?

  6. wrboyce
    Posted 10 years ago #

    duh, "AllowOverride None"... panic over! oops!

Topic Closed

This topic has been closed to new replies.

About this Topic