WordPress.org

Support

Support » How-To and Troubleshooting » Moved blog – now not working

Moved blog – now not working

  • I really am in need of some help here.

    I have a small test blog that I used solely for test purposes on my local machine. XP Pro – all updated. I had the blog working fine using Apache 2.2. And I wanted to run a second host instance for another unrelated system I’m trying out on the same machine. So I used what’s called “virtual hosting” in Apache. I moved (copied) the entire file structure from /localhost/wordpress (which was actually at c:/program files/Apache 2.2/htdocs/) to c:/svdp/wordpress. I did not touch mySQL nor PHP. I also introduced the other host software. The other host software works fine with the new virtual host container. The WP blog does not.

    When I browse to http://blog (the name of the new blog’s virtual home according to Apache) I get a text version of the blog. No theme, very little formatting, no colors, no background – just plain text. If I click on any of the links on this “text only” website, I get a 403 (Yes, I’m on the admin account). The only link that works is one at the bottom pointing to the main WordPress.org site.

    Thing I don’t get is why did it break when I simply moved it from one folder tree to another? I thought these things were supposed to be “portable”. There must be other files/structures that have to be moved along with it but I don’t know what they are. I know that this text-only website is the one I had working because, for instance the Title shows it is the one I set up.

    Can someone please tell me what else I should “move” or copy to what postion, in order to get this back to a working state?

    Thanks, all.

    HerbS

Viewing 5 replies - 1 through 5 (of 5 total)
  • Roy
    Member

    @gangleri

    Did you read this?:
    codex.wordpress.org/Moving_WordPress

    Maybe this too:
    codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    Thanks Gangleri. I’d missed that reference totally. But now I’m really screwed!

    I followed the instructions to the letter however, I mistakenly typed in the wrong URI in both WP Address and Blog Address. I think I know now what I should have done/typed, but now it seems I won’t be able to go back unless….

    Could you or someone please tell me what file I can go to and edit to reinstate the working version/state so I can then go in a re-type a correct address in those fields???

    I did go to wp-config.php to see if the references are stored there. They aren’t.

    I’m totally bummed!

    HerbS

    Samuel B
    Participant

    @samboll

    Ahhh – genius!
    Thanks very much.
    Now I’m going to take it more slowly and read fully. I’d like to maybe use the “backupu”, export/import idea. And not kill the old one before I know the new one works. Shoulda, woulda, coulda…

    HerbS

    Still trying to sort this out. Can I get one more thing from ya…

    It says in the doc:

    In the box for WordPress address (URL): change the address to the new location of your main WordPress core files. Example: http://example.com/wordpress
    In the box for Blog address (URL): change the address to the root directory’s URL. Example: http://example.com

    Remember, I’m not at a .com but sitting at the computer at home. I take the term “core files” to mean the folder “wordpress” and all folders beneath it – right? Suppose I want the blog’s file structure to now reside in C:/svdp/. So, if I have the blog now coming out of
    http://localhost/ but physcially located in
    C:/Program Files/Apache Software Foundation/Apache2.2/htdocs/wordpress (and all folders underneth it) When I change things around, I’ll have copied (not moved) all the core files from their present physical location to c:/svdp/wordpress, Apache’s DocumentRoot set at C:/svdp and the <Directory> set to “C:/svdp/wordpress” – right? Then, turning this on, in the “old” admin – settings – General I want to fill in WordPress address (URL) with this: http://C:/svdp/ in both the WordPress Address and Blog Address fields – right? Restart Apache to apply it’s new environment settings.

    Guess I’m having real trouble understanding this /localhost/ business.

    I just don’t want to screw this up – again!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Moved blog – now not working’ is closed to new replies.