Support » Fixing WordPress » Moved blog index to root – settings > permalinks page blank

  • Resolved icerabbit

    (@icerabbit)


    Hi,

    I had my wordpress install in a subfolder /blog/
    Decided to move the blog to the root of the site.
    Followed the instructions regarding giving wordpress its own folder.

    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    This was successful.
    The blog is displayed as the site root, pages & post links work.
    I can log in as admin via /blog/wp-login.php
    Everything in the admin seems normal there, apart from one thing (so far):

    the Settings > Permalinks section remains black?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Something similar happened to this guy here:
    http://wordpress.org/support/topic/260164?replies=3

    Maybe post over there and see if they got it fixed and how.

    I resolved my issue. Sometimes the problem can be with the instructions.

    I thought it had to have something to do with the .htaccess file.

    In the root I already had a .htaccess file. So when I did step 7, I set the old htaccess aside and copied the one from /blog (which generally would be /wordpress) over to root.

    Searching didn’t really yield the answer, so I figured I would compare the two files for any lacking code. Sure enough.

    In my case the .htacceess file from inside /blog lacks a first line I had in the root .htaccess:

    AddHandler php5-script .php

    Which likely is present due to my provider allowing to select php4 or php5 via the hosting control panel.

    Once I restored my original .htaccess file (which included the 8 lines of required wordpress code by the way) the preferences permalinks page returned.

    Hopefully this will help resolve the problem for somebody with the same issue.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Moved blog index to root – settings > permalinks page blank’ is closed to new replies.