WordPress.org

Forums

move blog from /blog to root (4 posts)

  1. sydneycraig
    Member
    Posted 3 years ago #

    hi all

    i have developed a site on mydomain.com/blog whilst the root has the current static website....

    i now want to move the WP site to the root and delete the current static site

    i looked at http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory but i think i want the opposite of this??!!

    how do i move the /blog to the root??

    as far as i can see i need to change the uri and url settings in admin then copy the index.pgp and httaccess files into the root???

    corect??

    many thanks in advance

  2. kayjayone
    Member
    Posted 3 years ago #

    The link you provided above (giving wordpress its own directory) has the basic steps, just need a few modifications for your situation…

    1. Nothing to do, you already have the /blog directory

    2. Same, go to Settings -> General

    3. Don’t change the address in the WordPress Address (URL) box, it should read mydomain.com/blog

    4. Change the Site Address (URL) to mydomain.com (without the /blog directory)

    5. Same, click Save Changes, although you’ll still be able to access the admin since the URL did not change

    6. Skip this step

    From here on out the steps 7-11 will be the same…

  3. sydneycraig
    Member
    Posted 3 years ago #

    thansk so much
    i have managed to do this and the site views fine but not sure about no 11

    If you have set up Permalinks, go to the Permalinks panel and update your Permalink structure. WordPress will automatically update your .htaccess file if it has the appropriate file permissions. If WordPress can't write to your .htaccess file, it will display the new rewrite rules to you, which you should manually copy into your .htaccess file (in the same directory as the main index.php file.)

    if the site shows ok and links work do i assume premalinks are set ok?!
    it is set to Month and name http://www.mydomain.com.au/2011/05/sample-post/

    many thanks again

    craig

  4. kayjayone
    Member
    Posted 3 years ago #

    Yes if it views ok and links work everything should be fine. I usually go to the Permalinks page and without changing anything click the Save Changes button just for good measure. Glad it's all working!

Topic Closed

This topic has been closed to new replies.

About this Topic