Support » Plugin: WP Ajaxify Comments » Mouse is "busy" after next page of comments

  • Resolved bhagwad

    (@bhagwad)


    First, let me congratulate you on a truly magnificent plugin. It’s unbelievable and has everything I can think of for Ajaxifying comments.

    I have comements paging enabled and I use the Atahualpa theme so in the “Comment paging links selector” I’ve entered “.page-numbers”. Also, as per another post, in the “‘OnBeforeSelectElements’ callback” I have the following:

    (jQuery('td#middle > #comments', dom).length > 0) ?
    jQuery('td#middle > #comments, ul.commentlist', dom).wrapAll('<div id="commentsWrapper" />')
    : jQuery('<div id="commentsWrapper" />').insertBefore(jQuery('#respond', dom));

    My problem is that when I click on a new page, the comments refresh as expected, but the mouse never returns to normal. It remains “busy” so to speak. I can’t click anything. I’m disabling the plugin for now, but here’s a sample post on my blog: http://www.bhagwad.com/blog/2012/philosophy/abortion-do-you-value-the-life-of-a-human-above-that-of-an-animal.html/

    Hope this makes sense! And once again, thank you for a fantastic effort.

    http://wordpress.org/extend/plugins/wp-ajaxify-comments/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author janjonas

    (@janjonas)

    Hi bhagwad,

    thanks for your comment.

    Does the loading popup disappear and the mouse cursor is still in the loading state?

    Please enable the debug mode of the plugin and send me the debug/console output of the that is logged when using the paging feature.

    Thanks for the response!

    No, the loading popup doesn’t disappear. It remains with the mouse cursor in the busy state. Here’s the console output.

    Resource interpreted as Font but transferred with MIME type application/x-font-woff: "data:application/x-font-woff;charset=utf-8;base64,d09GRgABAAAAAC9UABEAAAAAT…H/hbABjQBLsAhQWLEBAY5ZsUYGK1ghsBBZS7AUUlghsIBZHbAGK1xYWbAUKwAAAAFRjJ+7AAA=". www.bhagwad.com/:606
    Resource interpreted as Font but transferred with MIME type font/woff: "https://ssl.gstatic.com/fonts/roboto/v8/grlryt2bdKIyfMSOhzd1eA.woff". plusone.google.com/_/widget/render/comments?bsv&href=http%3A%2F%2Fwww.bhagw…=I2_1369593367496&parent=http%3A%2F%2Fwww.bhagwad.com&rpctoken=31445969:19
    Resource interpreted as Font but transferred with MIME type font/woff: "https://ssl.gstatic.com/fonts/roboto/v8/vxNK-E6B13CyehuDCmvQvw.woff". plusone.google.com/_/widget/render/comments?bsv&href=http%3A%2F%2Fwww.bhagw…=I2_1369593367496&parent=http%3A%2F%2Fwww.bhagwad.com&rpctoken=31445969:19
    Resource interpreted as Font but transferred with MIME type font/woff: "https://ssl.gstatic.com/fonts/roboto/v8/d-QWLnp4didxos_6urzFtg.woff". plusone.google.com/_/widget/render/comments?bsv&href=http%3A%2F%2Fwww.bhagw…=I2_1369593367496&parent=http%3A%2F%2Fwww.bhagwad.com&rpctoken=31445969:19
    Unknown RPC service: widget-interactive-I1_1369593367487 /https://apis.google.com/_/scs/apps-static/_/js/k=oz.gapi.en_US.r3QWApkN4KM.O/m=comments,plus,pluso…:5
    Unknown RPC service: widget-interactive-I0_1369593367481 /https://apis.google.com/_/scs/apps-static/_/js/k=oz.gapi.en_US.r3QWApkN4KM.O/m=comments,plus,pluso…:5
    Unknown RPC service: widget-interactive-I2_1369593367496 /https://apis.google.com/_/scs/apps-static/_/js/k=oz.gapi.en_US.r3QWApkN4KM.O/m=comments,plus,pluso…:5
    [WP-Ajaxify-Comments] Initializing version 0.13.0 /http://www.bhagwad.com/blog/wp-content/plugins/wp-ajaxify-comments/wp-ajaxify-comments.js?ver=0.13…:7
    [WP-Ajaxify-Comments] Found jQuery 1.8.3 /http://www.bhagwad.com/blog/wp-content/plugins/wp-ajaxify-comments/wp-ajaxify-comments.js?ver=0.13…:7
    [WP-Ajaxify-Comments] Found jQuery blockUI 2.57 /http://www.bhagwad.com/blog/wp-content/plugins/wp-ajaxify-comments/wp-ajaxify-comments.js?ver=0.13…:7
    [WP-Ajaxify-Comments] Search comment form (selector: '#commentform')... Found:
    [form#commentform, context: document, selector: "#commentform", constructor: function, init: function, selector: ""…]
    0: form#commentform
    context: document
    length: 1
    selector: "#commentform"
    __proto__: Object[0]
     /http://www.bhagwad.com/blog/wp-content/plugins/wp-ajaxify-comments/wp-ajaxify-comments.js?ver=0.13…:7
    [WP-Ajaxify-Comments] Search comments container (selector: '#commentsWrapper')... Found:
    [div#commentsWrapper, context: document, selector: "#commentsWrapper", constructor: function, init: function, selector: ""…]
    0: div#commentsWrapper
    context: document
    length: 1
    selector: "#commentsWrapper"
    __proto__: Object[0]
     /http://www.bhagwad.com/blog/wp-content/plugins/wp-ajaxify-comments/wp-ajaxify-comments.js?ver=0.13…:7
    [WP-Ajaxify-Comments] Search respond container (selector: '#respond')... Found:
    [div#respond, context: document, selector: "#respond", constructor: function, init: function, selector: ""…]
    0: div#respond
    context: document
    length: 1
    selector: "#respond"
    __proto__: Object[0]
     /http://www.bhagwad.com/blog/wp-content/plugins/wp-ajaxify-comments/wp-ajaxify-comments.js?ver=0.13…:7
    [WP-Ajaxify-Comments] Search comment paging links (selector: '.page-numbers')... Found:
    [a.prev page-numbers, a.page-numbers, a.page-numbers, a.page-numbers, span.page-numbers current, a.prev page-numbers, a.page-numbers, a.page-numbers, a.page-numbers, span.page-numbers current, prevObject: v.fn.v.init[1], context: document, selector: ".page-numbers", constructor: function, init: function…]
    0: a.prev page-numbers
    1: a.page-numbers
    2: a.page-numbers
    3: a.page-numbers
    4: span.page-numbers current
    5: a.prev page-numbers
    6: a.page-numbers
    7: a.page-numbers
    8: a.page-numbers
    9: span.page-numbers current
    context: document
    length: 10
    prevObject: v.fn.v.init[1]
    selector: ".page-numbers"
    __proto__: Object[0]
     /http://www.bhagwad.com/blog/wp-content/plugins/wp-ajaxify-comments/wp-ajaxify-comments.js?ver=0.13…:7
    [WP-Ajaxify-Comments] Initialization completed /http://www.bhagwad.com/blog/wp-content/plugins/wp-ajaxify-comments/wp-ajaxify-comments.js?ver=0.13…:7
    JQMIGRATE: Logging is active s2.wp.com/:9620

    Hope I pasted the right output!

    Plugin Author janjonas

    (@janjonas)

    Hi,

    could you please paste the debug output that is generated when you click on one of the paging links, i.e. when your site gets into the “error” state where the popup does not disappear.

    Could you send me a link to a page where I can reproduce the problem? This would be much easier for me to find the cause of the issue. You can send me a private message here http://blog.janjonas.net/contact.

    Hi,

    I’ve whipped up a test post on a related domain of mine to replicate the issue. Here’s the URL: http://www.bhagwad.com/test/

    I’ve enabled debugging within the plugin so hopefully you can find what’s wrong! I hope this helps…

    Regards,
    Bhagwad

    Plugin Author janjonas

    (@janjonas)

    Hi,

    Please try out the new developer version 0.13.1 (http://downloads.wordpress.org/plugin/wp-ajaxify-comments.zip). Please let me know, if the new version fixes your problem.

    Best regards,
    Jan

    Just sent you a mail with some feedback about the new version and problems with changing the comment page more than once…

    Regards,
    Bhagwad

    Plugin Author janjonas

    (@janjonas)

    Ok, this is a configuration issue now. The paging links are not nested in the comments container and are not updated.

    Please try the following settings:

    Comments container selector
    #wpacContainer

    ‘OnBeforeSelectElements’ callback:
    jQuery('#commentsWrapper, .navigation-comments-above, .navigation-comments-below', dom).wrapAll('<div id="wpacContainer" />');

    Hope this helps…

    I used your suggested settings on the test site. While the paging links are updating correctly, the actual comments don’t change!

    Awfully sorry for all this. Does the plugin work well with the Atahualpa theme?

    Plugin Author janjonas

    (@janjonas)

    Please try to change the the ‘OnBeforeSelectElements’ callback to:

    jQuery('#comments, #commentsWrapper, ul.commentlist, #respond, .navigation-comments-above, .navigation-comments-below', dom).wrapAll('<div id="wpacContainer" />');

    It seems to be finally working! Awesome! I can’t thank you enough. Marking issue as resolved.

    Never had such great support from a plugin author. Thank you again!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Mouse is "busy" after next page of comments’ is closed to new replies.