• Resolved Jabed Shoeb

    (@onnoysomoy)


    The “Most Popular Products by Pageviews” data loading failed. While hunting for a solution, I utilized the plugin “Health Check & Troubleshooting” to determine which plugin was causing the problem. Surprisingly, I identified the the cause: the “Woocommerce” plugin. When deactivated, data loaded normally, but when activated, it failed.

    The problem is that I can’t uninstall WooCommerce because our website is an e-commerce site. So, can you help with the workaround? Your assistance will be much appreciated.

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Support James Osborne

    (@jamesosborne)

    Thanks for reaching out @onnoysomoy, and sorry to hear that your encountering a “data load failed” error. So we can determine more on this, please share the following:

    1. Your Site Health information. You can use this form to share privately if preferred.  
    2. Were you able to view data for the most popular product previously, within the Site Kit dashboard, or has this always occurred?
    3. When checking the Site Kit dashboard from a Chrome browser incognito window does the same occur? If so, please share any browser console errors that appear. 

    Let me know if you have any questions with the above.

    Thread Starter Jabed Shoeb

    (@onnoysomoy)

    1. form submitted.
    2. Yes, This features was always shown but recently I noticed the issue. So, I cant exactly tell when started.
    3. Console error given below:

    JQMIGRATE: Migrate is installed, version 3.4.1
    /wp-json/google-site-kit/v1/core/user/data/survey-trigger?_locale=user:1

       Failed to load resource: the server responded with a status of 503 ()

    googlesitekit-api-6b06a5c9b165bf7e28a4.js:3 Google Site Kit API Error method:POST datapoint:survey-trigger type:core identifier:user error:”The response is not a valid JSON response.”
    (anonymous) @ googlesitekit-api-6b06a5c9b165bf7e28a4.js:3
    /wp-json/google-site-kit/v1/modules/analytics-4/data/report?metrics%5B0%5D%5Bname%5D=screenPageViews&dimensions%5B0%5D%5Bname%5D=pagePath&startDate=2024-02-01&endDate=2024-02-28&dimensionFilters%5BcustomEvent%3Agooglesitekit_post_type%5D%5BfilterType%5D=stringFilter&dimensionFilters%5BcustomEvent%3Agooglesitekit_post_type%5D%5BmatchType%5D=EXACT&dimensionFilters%5BcustomEvent%3Agooglesitekit_post_type%5D%5Bvalue%5D=product&orderby%5B0%5D%5Bmetric%5D%5BmetricName%5D=screenPageViews&orderby%5B0%5D%5Bdesc%5D=true&limit=3&_locale=user:1

       Failed to load resource: the server responded with a status of 400 ()

    googlesitekit-api-6b06a5c9b165bf7e28a4.js:3 Google Site Kit API Error method:GET datapoint:report type:modules identifier:analytics-4 error:”Field customEvent:googlesitekit_post_type is not a valid dimension. For a list of valid dimensions and metrics, see https://developers.google.com/analytics/devguides/reporting/data/v1/api-schema
    (anonymous) @ googlesitekit-api-6b06a5c9b165bf7e28a4.js:3
    report:1

       Failed to load resource: the server responded with a status of 503 ()

    googlesitekit-api-6b06a5c9b165bf7e28a4.js:3 Google Site Kit API Error method:GET datapoint:report type:modules identifier:analytics-4 error:”The response is not a valid JSON response.”
    (anonymous) @ googlesitekit-api-6b06a5c9b165bf7e28a4.js:3
    u @ googlesitekit-vendor-dfed20715cb9adaf207b.js:7
    (anonymous) @ googlesitekit-vendor-dfed20715cb9adaf207b.js:7
    forEach.e. @ googlesitekit-vendor-dfed20715cb9adaf207b.js:7
    n @ googlesitekit-vendor-dfed20715cb9adaf207b.js:1
    s @ googlesitekit-vendor-dfed20715cb9adaf207b.js:1

    Plugin Support James Osborne

    (@jamesosborne)

    Appreciate the update and for sharing your Site Health information. As I noticed some additional .htaccess rules, can you visit your permalinks page (Settings > Permalinks) and press the “Save change” button? This will recreate a fresh .htaccess file for you. I ask as rules applied at .htaccess level can impact Site Kit behavior.

    If the same occurs, please share the following:

    1. Do you see any warnings or errors when checking yourSite Health status  (Tools > Site Health > Status), which differs from your Site Health information requested above? Such errors may include REST endpoint references.
    2. A particular URL of your site that contains one of your most popular products, which you would typically expect to be listed in the associated key metric widget.

    Note also that I added your details to this existing GitHub issue, as this was reported by other users previously. Hopefully, with a little more troubleshooting we can determine the cause.

    I’m having the exact same error Jabed is having here.

    1) ITt shows no relevant error when accessing it via Tools – Site Healt – Status: https://i.imgur.com/xXqqeGd.png

    2) https://yubi-verlag.com/produkt/affirmationskarten-fuer-kinder-kaufen/

    Plugin Support James Osborne

    (@jamesosborne)

    Sorry to hear that @yavuzyayla, and appreciate you sharing these insights. As we are investigating reports of this, it would be great if you could open an individual support topic we can communicate with you from there. We can then perform some troubleshooting and add your details to the related GitHub issue.

    After opening a topic, you may wish to share your Site Health information and a specific product page on your site that you would expect to see in this table (your most popular product). Thank you!

    Thanks @james Osborne, done what you said. Appreciate the help.

    Thread Starter Jabed Shoeb

    (@onnoysomoy)

    1. Site Health errors now showing only 3. check screenshot please. https://prnt.sc/iJzNKN9ZW4xl
    2. https://www.csi.com.bd/product/dahua-dhi-lm25-e231-25-inch-fhd-ips-monitor/

    Thank you for your support.

    Plugin Support James Osborne

    (@jamesosborne)

    Thanks for sharing this additional information @onnoysomoy. I can see that on the sample page you provided, this looks to use a standard WooCommerce product content type. I’m currently testing this further while I’ll also check this with the team to see if this could be related to a WooCommerce extension. I’ll keep you updated here with any updates.

    While I’m checking this further, if you do wish to perform a further check on this, the below may be of use:

    1. Login to your live site from a Chrome browser incognito window.
    2. Navigate to “Plugins > Health Check & Troubleshooting > Troubleshoot” (I can see that you already have the Health Check & Troubleshooting plugin active)
    3. From the same screen click on the “Available Plugins” tab at the top right and then click on the “Enable” option next to “Site Kit by Google“ and also WooCommerce (without enabling any further extensions.
    4. Visit the Site Kit dashboard once more and check for the same error. Note that you may need to change the reporting period so the plugin requests a fresh update of data.

    Let me know if you have any questions with the above.

    Plugin Support James Osborne

    (@jamesosborne)

    Thanks for your patience on this @onnoysomoy. I added some workaround steps to the related GitHub issue which will allow you to view the “Most popular products” key metrics tile once more.

    Can you follow these steps, or let me know if you have any questions on this.

    Plugin Support James Osborne

    (@jamesosborne)

    As we didn’t receive a response I’ll mark this as resolved. Feel free to open a new support topic if you continue to encounter issues, or reopen this topic and we’d be happy to assist.

    Thread Starter Jabed Shoeb

    (@onnoysomoy)

    @jamesosborne, extremely sorry for late reply.

    Followed your March 6, 2024 instruction but same error occured.

    Normally I dont use chrome, so, you can say this is fresh browser without cache.

    01. Opened chrome incognito tab window and Log in to website admin.

    02. Went to “Tools -> Site Health -> Troubleshooting” & enable troubleshooting.

    03. Went to plugin page. First enabled sitekit and checked dashboard to see if data is showing. YES, data is showing. Now, enabled “Woocomerce”, and checked dashboard to see Error appeared.

    Tried changing reporting period but data display error still showed.

    Hope, above will help to investigate further to resolve this issue. Thank you.

    Plugin Support James Osborne

    (@jamesosborne)

    No problem @, I’ve reopened this support topic. In order to resolve this, please follow the steps below:

    1. Click on the “Change metrics” option from your Site Kit dashboard
    2. Deselect the “Most popular products by pageviews” metric
    3. Click on the “Apply changes” button
    4. You will see on your Site Kit dashboard that this tile no longer exists. Click on the “Change metrics” link once more
    5. Select the “Most popular products by pageviews” metric once more. You will see a notice that your Analytics property will be updated.
    6. Click on the “Apply changes” button
    7. You may see the Data loading failed error once more, but please wait an hour as we cache responses.
    8. Wait some time before visiting your Site Kit dashboard once more, checking the “Most popular products” key metrics tile.

    Let me know how you get on with the above. Note also that we will have a fix coming out for this soon, with more details found here.

    Thread Starter Jabed Shoeb

    (@onnoysomoy)

    Hi,

    Thank you. Above steps make the issue go away. “Most popular products by pageviews” is showing data properly now. Thank ykou.

    Plugin Support James Osborne

    (@jamesosborne)

    Glad to hear it @onnoysomoy, appreciate the update. If you run into any further errors or if you have any Site Kit related queries, be sure to get in touch.

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.