Support » Plugin: Site Reviews » Most of the readers are unable to leave their review

  • Blogger

    (@rui-oliveira)


    For some reason, the plugin does not work properly.

    Most of our readers are unable to leave a review.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Gemini Labs

    (@geminilabs)

    @rui-oliveira There are a few reasons that this can happen, these are all outlined on the Site Reviews Help page.

    Here is what the Site Reviews Help page says:

    1. Does your website have a SSL certificate? If it does, make sure that your website is configured to always use it by using a SSL plugin such as Really Simple SSL. Site Reviews will use HTTPS to submit a review if possible, but if your site has a valid SSL certificate and you are viewing the website using HTTP (instead of HTTPS) then the browser will detect this as a cross-domain request and prevent the review submission from completing.
    2. Have you enabled the reCAPTCHA setting? If you have, make sure that the “Site Key” and “Site Secret” have been entered and that they were generated for the Invisible reCAPTCHA badge (Google provides three different types of reCAPTCHA). Also, make sure that you correctly entered your website domain when creating the “Site Key” and “Site Secret”.
    3. Have you used a security plugin to disable access to /wp-admin/admin-ajax.php on the frontend of your website, or have you disabled /wp-admin/ access for non-administrators? If you have, then it’s possible this is preventing Site Reviews from submitting reviews.
    4. If the review is created but the button keeps spinning, then your server is likely not configured to send email and is preventing WordPress from sending the email notifications. You will need to either disable the notification setting for new reviews, or fix the problem on your server.

    If you create a topic on the WordPress Support Forum, I’ll be happy to help you solve this problem which is likely specific to your website and plugin configuration.

    All topics on the support forum are generally responded to within 24 hours of posting (if not sooner).

    EDIT:

    However, in your case I can see that this problem is being caused by your Cloudflare settings. Please see my replies below for the solution.

    • This reply was modified 7 months, 1 week ago by Gemini Labs.
    • This reply was modified 7 months, 1 week ago by Gemini Labs.
    Plugin Author Gemini Labs

    (@geminilabs)

    @rui-oliveira One more thing: you created a topic on the forum a month ago but never responded to my reply which is why I closed the topic.

    When I attempted to submit a review on the URL you provided, I got a 503 HTTP status error during the review submission when Site Reviews made a request to /wp-admin/admin-ajax.php on your website.

    503 errors are frequently temporary. It could be due to server maintenance was being done and the server could not reply correctly. Another reason for 503 errors is that the server is simply overloaded. This too is usually temporary and normal operation resumes shortly. If you are still getting 503 errors, it’s an indication of a chronic server resource issue (lack of adequate resource actually) that your host needs to address.

    A bit of Google searching led me to this page: https://www.digitalocean.com/community/questions/can-t-solve-a-503-admin-ajax-get-error-with-my-wordpress-website

    And the solution on that page is this:

    This was an issue with some Page Rules and Cloudflare. In the past I’ve setup rules to protect the WordPress admin but this specific plugin was being blocked by Cloudflare.

    Not sure if it will be the same case for you but I usually setup added page rules in my Cloudflare account for the WordPress admin (wp-admin) section. One of them was One of theme involved security level set to “Im Under Attack”, I changed that to High and things started working again.

    Since I can see that your website is using Cloudflare, this is likely the cause of the problem and the solution above should help you to solve it.

    • This reply was modified 7 months, 1 week ago by Gemini Labs.
    Plugin Author Gemini Labs

    (@geminilabs)

    Thread Starter Blogger

    (@rui-oliveira)

    Hi,

    For some reason, I didn’t get the notification on your reply.

    1 – SSL is not the issue, since the site was built with SSL. And in Cloudflare is Your SSL/TLS encryption mode is Full (strict)

    2 – Not using reCaptcha

    3 – Don’t think so, but to be honest, don’t even know where to search about this.

    4 – I just disable the email sending, and I will test, but I don’t think so, since I still get reviews, but 1 in 10 the rest does not work.

    Plugin Author Gemini Labs

    (@geminilabs)

    @rui-oliveira did you read my last replies here about Cloudflare?

    Specifically this which I believe to be the same issue you are experiencing: https://www.digitalocean.com/community/questions/can-t-solve-a-503-admin-ajax-get-error-with-my-wordpress-website

    I further confirmed this by trying to load the admin-ajax.php file on your website directly (which is what Site Reviews and many other plugins use for Ajax requests) which redirected me to Cloudflare’s DDOS protection page.

    Thread Starter Blogger

    (@rui-oliveira)

    About Cloudflare rules, I have one, check it (I uploaded it into my site)
    https://thebinaryoptionsblog.com/wp-content/uploads/2021/10/2021-10-22_205308.png

    Can be that?

    About Hosting, I am using Kinsta, so I don’t think the issue can come from there.

    Plugin Author Gemini Labs

    (@geminilabs)

    Plugin Author Gemini Labs

    (@geminilabs)

    I recommend you also read this: https://turbofuture.com/internet/Cloudflare-Firewall-Rules-for-Securing-WordPress

    Specifically: “3. Protect the wp-admin Area” which tells you how to protect wp-admin without blocking admin-ajax.php.

    Thread Starter Blogger

    (@rui-oliveira)

    I will read it and then try again.

    Thanks for your help.

    Plugin Author Gemini Labs

    (@geminilabs)

    @rui-oliveira

    If this helped you to solve it and the problem was caused by a Cloudflare Firewall rule, would you consider changing your rating?

    Plugin Author Gemini Labs

    (@geminilabs)

    @rui-oliveira Was this resolved?

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Most of the readers are unable to leave their review’ is closed to new replies.