Support » Plugin: FakerPress » Most of the featured image links appear to be invalid

  • Resolved Lazlo Toth

    (@lazlo-toth)



    I have had trouble for the past few months with the featured images not being created. This is the primary reason that I use the plugin, so I can test a site to see how posts with images look. 🙂

    I noticed today that my media folder has a bunch of new entries that were created by your plugin…but they don’t have any photos attached to them.

    Here is a screen capture that will hopefully help you debug this problem:

    https://c1.staticflickr.com/5/4365/36946751596_cb8c4eb589_o.png

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Gustavo Bordoni

    (@bordoni)

    Hi @lazlo-toth,

    Thanks for reporting this bug, I never saw this bug on my testing but other folks have had this problem when dealing with bigger images. Can you check what I talked about on this other topic?

    https://wordpress.org/support/topic/featured-image-still-missing/

    If none of it works let me know I will gladly debug it further with you so I can get a code fix inside of FakerPress.

    Version: 0.4.1 imports all of the featured images correctly.

    Plugin Author Gustavo Bordoni

    (@bordoni)

    Thanks @lazlo-toth,

    That information lets me know what is the problem and I will fix it in the next version.

    My Best Regards

    Version 0.4.1 gives me a php error, but version 0.4.7 works great.

    In 0.4.9 the featured images don’t get downloaded right, and they don’t get added to posts. Also I’ve had problems with the post excerpt for the first post in the loop. It showed completely different text, and the_excerpt() didn’t stop after a few words: it printed 3 whole paragraphs of lorem ipsum that were not in the post content. 0.4.7 doesn’t have any issue.

    Thank you.

    Plugin Author Gustavo Bordoni

    (@bordoni)

    Hi @bogmuscalu,
    I found the problem with the images, I should be fixing it on our next version.

    Currently, I am working on a documentation website for us to have all the filters and action displayed correctly as well as how to use the plugin and what to expect.

    Important to note, the excerpt behavior is what was intended by design, on version 0.4.9 I’ve added the Excerpt to be randomly generated and the field to be filled on the database, but I guess I should have added a way for people to have a percentage change of it occurring.

    My Best regards,

    Great! Thank you Gustavo.

    Hi Gustavo, just checking to see if you have made any progress with a fix for the missing images problem. Thanks.

    Plugin Author Gustavo Bordoni

    (@bordoni)

    Hi @lazlo-toth,
    Sorry for the Huge delay on this version release.

    I figured out the problem, actual it was more than one.

    First I added a fall back to wp_remote_get to use file_get_contents due to for reasons I don’t get some servers do like the wp_remote_get.

    Second problem was that Lorem Pixel was very slow, and it was causing images to fail.

    So with version 0.4.10 it should be fixed.

    Great. Thanks for following up, it’s much appreciated. Looking forward to trying the new release.

    Burhan Nasir

    (@burhandodhy)

    Hi @gustavo Bordoni

    The attachment problem is still there in the new version. Most of the images are corrupted http://prntscr.com/igp5a9

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Most of the featured image links appear to be invalid’ is closed to new replies.