Support » Plugin: WP REST Cache » Most of the endpoints are showing as expired

  • Is there anything should I configure before it start caching? Somehow all my endpoints appear as expired in the list of cached rest api list.

    • This topic was modified 2 years, 3 months ago by metawise.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Acato

    (@acato)

    Hi @metawise

    No it should start caching without any extra configuration. There are however two situations (we know of) in which this might happen:

    1. If your server is using FastCGI: This is a known bug, see https://wordpress.org/support/topic/question-about-custom-endpoints/#post-11711843 We are working on a fix, which I expect to be releasing this week.

    2. If you are using Memcache(d) as external object cache. In this case you should see a message in wp-admin: WP REST Cache: We have detected you are using external object caching. If you are using Memcache(d) as external object cache, please make sure you visit this plugin's settings page and check the Using Memcache(d) checkbox. Please follow the instructions from this message and it should be solved.

    Please let us know if any of these two situations applies to you.

    I’m having the same problem, without using FastCGI or memcache(d).
    The endpoint caches expire after couple of minutes.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Most of the endpoints are showing as expired’ is closed to new replies.