Support » Fixing WordPress » Most of my Images are no longer showing in Media Library and Chrome Browsers

  • Resolved seojagaban

    (@seojagaban)


    Hi there,

    Please, I am battling with a very serious problem on my blog and you really need to help me as much as you can regarding this problem.

    Frantically, I have searched for solutions all over the net but I could not implement any.

    The images on my blog, SEOJagaban.com, do not load at all on Chrome browsers, not all though, but most of them do not show. Surprisingly, these same images are displayed if I use browsers like Edge.

    Now, I thought it was caused as a result of some plugins I am using. but when I did plugin testing by disabling all the plugins, the issue still persisted. Again, I suspected the themes and I disabled it as well, still no difference.

    Some experts opine that the issue is likely caused as a result of inadequate permissions given to the appropriate folders and files. I got the name of those folders and gave the right permission, as a I speak, none of these solutions are working.

    Please, you really need to help me with this or give me suggestions on the right step to take. Please.

    Thanks in advance.
    Emmanuel.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • For some reason, your server does not respond nicely to the following HTTP Header sent by Chrome:

    Accept: image/webp,image/apng,image/*,*/*;q=0.8

    If I try without the image/webp part (so just image/apng,image/*,*/*;q=0.8), it works fine.

    Please check your .htaccess file for any special webp handling or talk to your hosting provider for further assistance.

    Thank you for responding. But, I don’t really understand all that you have said.
    Please, can you check out the .htaccess for me, so you can make more input?
    These are the codes below:

    
    # BEGIN WebP Express
    # The rules below are a result of the WebP Express options, WordPress configuration and the following .htaccess capability tests:
    # - mod_header working?: yes
    # - pass variable from .htaccess to script through header working?: yes
    # - pass variable from .htaccess to script through environment variable working?: yes
    <IfModule mod_rewrite.c>
      RewriteEngine On
    
      # Redirect to existing converted image in cache-dir (if browser supports webp)
      RewriteCond %{HTTP_ACCEPT} image/webp
      RewriteCond %{REQUEST_FILENAME} -f
      RewriteCond %{DOCUMENT_ROOT}/wp-content/webp-express/webp-images/doc-root/wp-content/$1.$2.webp -f
      RewriteRule ^/?(.+)\.(jpe?g|png)$ /wp-content/webp-express/webp-images/doc-root/wp-content/$1.$2.webp [NC,T=image/webp,E=EXISTING:1,L]
    
      # Make sure that browsers which does not support webp also gets the Vary:Accept header
      # when requesting images that would be redirected to existing webp on browsers that does.
      <IfModule mod_setenvif.c>
        SetEnvIf Request_URI "\.(jpe?g|png)$" ADDVARY
      </IfModule>
    
      # WebP Realizer: Redirect non-existing webp images to webp-realizer.php, which will locate corresponding jpg/png, convert it, and deliver the webp (if possible) 
      RewriteCond %{REQUEST_FILENAME} !-f
      RewriteRule ^/?(.+)\.(webp)$ /wp-content/plugins/webp-express/wod/webp-realizer.php [E=DESTINATIONREL:wp-content/$0,E=WPCONTENT:wp-content,NC,L]
    
      # Redirect images to webp-on-demand.php (if browser supports webp)
      RewriteCond %{HTTP_ACCEPT} image/webp
      RewriteCond %{REQUEST_FILENAME} -f
      RewriteCond %{QUERY_STRING} (.*)
      RewriteRule ^/?(.+)\.(jpe?g|png)$ /wp-content/plugins/webp-express/wod/webp-on-demand.php?%1 [E=REQFN:%{REQUEST_FILENAME},E=WPCONTENT:wp-content,NC,L]
    
      <IfModule mod_headers.c>
        <IfModule mod_setenvif.c>
          # Apache appends "REDIRECT_" in front of the environment variables defined in mod_rewrite, but LiteSpeed does not.
          # So, the next lines are for Apache, in order to set environment variables without "REDIRECT_"
          SetEnvIf REDIRECT_EXISTING 1 EXISTING=1
          SetEnvIf REDIRECT_ADDVARY 1 ADDVARY=1
    
          # Set Vary:Accept header for the image types handled by WebP Express.
          # The purpose is to make proxies and CDNs aware that the response varies with the Accept header. 
          Header append "Vary" "Accept" env=ADDVARY
    
          # Set X-WebP-Express header for diagnose purposes
          Header set "X-WebP-Express" "Redirected directly to existing webp" env=EXISTING
        </IfModule>
      </IfModule>
    
    </IfModule>
    <IfModule mod_mime.c>
      AddType image/webp .webp
    </IfModule>
    
    # END WebP Express

    Thank you!

    It seems you’ve installed a plugin called WebP Express (https://wordpress.org/plugins/webp-express/). It has either stopped working or it is disabled.

    Please check if you still have this plugin installed and active.

    If yes, and you still want to have it, you’ll have to contact the authors on the plugin support forum, here: https://wordpress.org/support/plugin/webp-express/

    If you no longer have the plugin active, please delete the .htaccess file from your server.

    WOW! This is awesome. Thank you very much. I am super glad and happy right now and you have no idea.

    You are a wizard (I meant that in a good way).

    Thank you for creating time to solve this problem for me. I really appreciate your help.

    May God replenish you.

    Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.