Support » Fixing WordPress » Most categories re-directing to localhost page?

  • For some reason, many of the category links on a site I am working on redirect to a localhost URL that is inactive or non-functioning. Some of the category links appear to work fine. Does anyone have any insight on this?

    • This topic was modified 2 years, 7 months ago by cma2032.
Viewing 6 replies - 1 through 6 (of 6 total)
  • 1. Try to resave the pretty permlinks settings. (No need to change them. Just visit SettingsPermalinks and click on Save Changes.)
    2. Check if you have any weird entries in .htaccess

    Thank you. I’ve saved the Permalinks page and saw no difference. I checked the .htaccess file and it looks fine.

    Before continuing, make sure you’ve cleared all caches (both browser cache and server side).

    Hmm. I guess next step would be that standard troubleshooting one: temporarily deactivating all plugins and reverting to a standard theme (like twentyseventeen).
    If this solves the issue, then putting things back again, one plugin at a time, until you find the culprit.

    If still no happiness is reached, then it may be time to talk to the hosting company (if applicable) in case they’ve got some additional server-side caching.

    Unfortunately I did talk to the hosting company already, which is GoDaddy in this case. They weren’t much help, as they basically just told me they didn’t know what the problem was (the first person I spoke with didn’t seem to understand what I was even talking about). They did flush the DNS and recommended a plugin for me to rebuild the databases, which didn’t affect the issue.

    Is there some other workaround I can try before disabling plugins, etc.?

    Not that I know of, I’m afraid.
    Perhaps someone else may chime in.

    I iguess you already checked “WordPress Address” and “Site Address” in Settings – General, right?

    Is there anything about localhost in your wp-config.php?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Most categories re-directing to localhost page?’ is closed to new replies.