Support » Plugin: Jetpack by WordPress.com » Mosaic gallery removed?

  • Resolved TheSupercargo

    (@thesupercargo)



    Since the latest Jetpack update I can no longer find the mosaic tiled gallery option. Also all the galleries on my site that are set to use the mosaic tiled gallery appear to have switched(?) to a “rectangular” format.

    See for example the gallery at the foot of this page:
    http://www.thesupercargo.com/brief-return-belgium/

    On this Jetpack page
    https://jetpack.com/support/extra-sidebar-widgets/gallery-widget/
    I find:
    “The Gallery Widget was removed from Jetpack with the release of WordPress 4.9 and it’s inclusion in core functionality.”
    There are NO LINKS from this page to the place where the gallery now resides.

    OK – but…
    1) where do I find the place you’ve switched the gallery to?
    2) Does this mean I have to go through the whole site and re-write the code for all the galleries where I had originally used the mosaic tiled gallery?

    Thanks for your advice.

    • This topic was modified 5 months, 1 week ago by  TheSupercargo.
Viewing 9 replies - 1 through 9 (of 9 total)
  • OK, maybe I’m misunderstanding “inclusion in core functionality”. Does this mean the galleries previously included in Jetpack have all been included in WP?

    I’m running WP 4.9.6 but the extra galleries are clearly NOT automatically included in the core functionality on my websites.

    How can I turn them on please?

    Plugin Contributor Stef

    (@erania-pinnera)

    Hi there, thanks for reaching out!

    If you head to your widget page, there a Gallery widget you can place on your widget areas. I tried creating one on my test site now and it seems to be working.

    To edit that gallery, head to the Gallery widget and click on “Edit Gallery”; you should be able to set it up the tiled mosaic layout.

    Hope that answers your question! Let me know how it goes. Thanks!

    Hi Stef and thanks for getting back to me.

    The only Gallery widget I see allows me to create a gallery with the following options.
    Link to: attachment page, file, none
    Columns: 1-9
    Random order checked or unchecked
    Size: thumbnail, medium, large, full size

    There are no other options and I cannot set a mosaic.

    This is exactly what I see if I try to set up a gallery in a post (which is what I want to do and what I was able to do before).

    So, sadly, this doesn’t solve my problem.

    Plugin Contributor Stef

    (@erania-pinnera)

    Uh, sorry it didn’t solve the problem.

    I was checking your Jetpack settings and I noticed you don’t have the tiled gallery module enable. Can you try enabling it and see how it goes?

    Head to the Jetpack Dashboard page, scroll it down till its very end and click on ‘Debug’. That leads you to another page where you should click on ‘Access the full list of Jetpack modules available on your site.’

    From there, look for the Tiled Gallery module and turn it on.

    If that won’t work, can you temporarily deactivate all your plugins and check if the problem gets fixes that way? If it works, then reactivate each plugin one-by-one to find out which one is causing problems. I’d like to rule out any potential plugin clashed 🙂

    Let me know what you find out, and thanks for sorting this out with me!

    Thank you Stef!

    It was not having the Tiled Gallery box checked in the list of modules that was causing the problem. Everything is working fine now.

    BUT

    1) I didn’t uncheck that box. So it must have reset to an unchecked default in the last upgrade. Now I need to double check to see what else my have changed.

    2) I still don’t understand why Jetpack has to hide all its great modules. Why isn’t there a direct link to the full list of modules from the Jetpack tab in WP’s left hand column? Putting the list under “Debug” at the very foot of the dashboard, and then under a further link puts me in mind of The Hitchhiker’s Guide to the Galaxy: hidden in the bottom of a locked filing cabinet, stuck in a disused lavatory with a sign on the door saying ‘beware of the tiger’. (Or something like that.)

    Anyway. Thank you for helping me.
    🙂

    • This reply was modified 5 months, 1 week ago by  TheSupercargo.

    Just like inform that if you disable load images from wordpress servers, this deactivate the tiled gallery and option no appear in media setting.
    Every time you make this.
    You need go to debug to activate the module.

    Maybe developers can fix this in one update.
    I hope arrive the message, thanks.

    Plugin Support lizkarkoski

    (@lizkarkoski)

    @guillermo77

    Good morning. Could you please start your own thread, as per the Forum Welcome?
    https://wordpress.org/support/plugin/jetpack#new-post

    Thank you!

    Guillermo77

    (@guillermo77)

    ok @lizkarkoski NP.

    Plugin Support lizkarkoski

    (@lizkarkoski)

    Thanks @guillermo77

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.