More than one subscriber (2 posts)

  1. Jan Donker
    Posted 4 years ago #

    When I installed PuSHPress on my self-hosted blog, and started using it, I didn't receive any pings. After wondering why and staring at the code a lot, I inserted some "mail" commands in the code, to find out what went wrong. To my surprise, it sent a ping to somebody else ( Google ), and then stopped. Looking a bit harder revealed that it uses the loading of a template to send the ping, and by default it is "require_once", but you can change this by setting a parameter. I did, and it worked. I assumed it would be fixed in a couple of days, but it wasn't.

    In send-ping.php, I added a second parameter like this :
    @load_template( ABSPATH . WPINC . '/feed-rss2.php', false );
    and this :
    @load_template( ABSPATH . WPINC . '/feed-atom.php', false );

    After that, it worked fine. I could subscribe as many times as I wanted.

  2. Ovidiu
    Posted 4 years ago #

    is this still the case with the current version?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • PuSHPress
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic