Support » Plugin: Quotes Collection » More than one instance of shortcode

  • Hello,
    I have made a class for the quote on a page and added two instances via shortcode.
    On the English page, everything appears to be fine.
    On the Hebrew page, a very strange thing is happening. When I place the second instance, half the page just disappears right upon loading. If I take the second one off, the page works again.
    This is the way I added the shortcode:

    <div class="quotcoll">
    <h4>כה אמרו חכמים<br />
    ציטוטים מפי אישים ששווה להקשיב להם:</h4>
    <p>[quotcoll tags="Hebrew" orderby="random" limit=2]</p>
    </div>

    It happened on another page, as well, and I have taken it off, for the time being.
    Can you help figure this out?
    Thank you,
    Vera

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Srini G

    (@srinig)

    Can you please put it on for some time so that I can check? Or just put it on for a moment, view source, and at the point where the page rendering stops, an error message could be displayed. If it does, just copy the message and paste it here, I’ll see what I can do.

    Srini,
    Thank you. It is there, you can check. I only took it off the second page, but it is there on the page I pointed to here. And you may see it’s English twin by clicking the flag on top, and there the two instances work.
    There is not error message, just an empty space.
    I’ll do some work tonight to add some more English and Hebrew and see, will let you know.
    Thank you for the help,
    Vera

    Hi,
    I have tried it on a few more posts (both Hebrew and English), and they work with 2 instances. This particular post (so far), however, doesn’t, and I don’t know why.
    When I take the second instance off – it’s fine.
    I repasted it from the template, in case it was somehow faulty – no change.
    I tried to move it further down the page – no change.
    I tried to remove the picture where the loading halts – it just shows two more paragraphs before stopping.
    Can you understand why this is?
    Thank you,
    Vera

    Plugin Author Srini G

    (@srinig)

    Whenever I visit the link you’ve provided, it seems to work just fine. Are you sure there is a problem, con you please provide a link to the page where the loading halts? You can also email me if you want me to look at it from inside the wp-admin.

    Hi,
    Well, the page I provided the link to IS the problematic page. How can I send you a screenshot? Don’t see a possibility here.
    http://test.eichut.net/2013/12/2013-12-01-16-25-03/
    Vera

    It has happened again in this post:
    http://test.eichut.net/2013/10/2013-10-13-20-28-24/
    I have two boxes designed. One on the right, one on the left.
    What I have just discovered is that is I make the second box the same as the first, both on the left, then it displays correctly. Tried it on both pages, it is true. (I returned it to the right side for now, to solve)
    But there are posts where both sides work well, like here:
    http://test.eichut.net/2013/08/2013-08-11-20-00-48/
    Can you help discover what is the problem?
    Vera

    • This reply was modified 2 months, 3 weeks ago by  beitsiach.

    Any news?

    Plugin Author Srini G

    (@srinig)

    I checked the links you provided just now, and It seems fine for me, or I haven’t understood the problem. What are the boxes you mention? The pullquote kind of thing you have on the page? They appear fine for me. Actually the link that you say works well looks problematic to me because the page seems to render twice.

    Please explain the exact issue and how you want things to work and I’ll be happy to help.

    If you don’t see the issue, I don’t know how to show you, without sending you a screenshot. I’ll happily provide some, But how to do that here?
    As soon as that is settled, there is another issue to do with the functionality: in cases of more than one instance, the quotes are the same.
    Thank you,
    Vera

    • This reply was modified 2 months, 2 weeks ago by  beitsiach.
    • This reply was modified 2 months, 2 weeks ago by  beitsiach.
    Plugin Author Srini G

    (@srinig)

    You can send your problems to srinig.com AT gmail dot com.

    I sent you an email.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.