WordPress.org

Forums

[resolved] [closed] More Tag not visible in the Visual Editor (11 posts)

  1. Denny
    Member
    Posted 2 years ago #

    Hi All,

    When I click on the "Insert More Tag" button in the WYSIWYG editor, the more tag line is not visible as it used to be. When I click on the Text tab, I can see that the <!--more--> tag is added, however it is not visible in the Visual tab.

  2. It's still visible for me. What theme are you using?

  3. Denny
    Member
    Posted 2 years ago #

    I can experience this with different themes, currently I have the TwentyTwelve theme activated and the only plugin activated is the Beta Tester plugin.
    I tried to trace the problem by comparing the WP 3.6 Beta 3 installation and another installation running WP 3.5.1

    In the WP 3.5.1 I found the img.mceWPmore class in the content.css file which displays the image:

    img.mceWPmore {
    	background: transparent url("img/more_bug.gif") no-repeat right top;
    }

    but I can't see this class in the 3.6 Beta 3 content.css file.
    I opened the file directly from the file system to make sure that it is not a caching problem, also I can see that this class is missing in the WP trunk content.css file as well:
    http://core.svn.wordpress.org/trunk/wp-includes/js/tinymce/themes/advanced/skins/wp_theme/content.css

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    Bug confirmed using Twenty Twelve, the Visual Editor & 3.6-beta3. When you insert the more tag, the cursor actually jumps up one line and you have no visual indication that the tag has been added.

    Both:

    img.mceWPmore {
        background: url("img/more_bug.gif") no-repeat scroll right top transparent;
    }

    and:

    img.mceWPnextpage, img.mceWPmore {
        -moz-border-bottom-colors: none;
        -moz-border-left-colors: none;
        -moz-border-right-colors: none;
        -moz-border-top-colors: none;
        border-color: #CCCCCC -moz-use-text-color -moz-use-text-color;
        border-image: none;
        border-right: 0 none;
        border-style: dotted none none;
        border-width: 1px 0 0;
        display: block;
        height: 12px;
        margin: 15px auto 0;
        width: 95%;
    }

    seem to be missing from content.css.

  5. esmi
    Forum Moderator
    Posted 2 years ago #

  6. esmi
    Forum Moderator
    Posted 2 years ago #

    Looks like it's just an issue with an older copy of the compressed .css file being bundled in with the nightlies. Thanks for the heads up on this one.

  7. Denny
    Member
    Posted 2 years ago #

    It's good to hear this :)

  8. That explains why I didn't see it :) I'm using uncompressed css/JS right now.

  9. Sapphire
    Member
    Posted 1 year ago #

    I never had this problem until installing 3.6. Now my More tags have disappeared. I can see them in the code, but not in the Visual view.

  10. jerethi99
    Member
    Posted 1 year ago #

    I am experiencing this issue now as well, using WP 3.6. Oddly, I was able to view the more image until recently. Something, although I don't know what, seems to have happened to have recently caused it to disappear.

  11. esmi
    Forum Moderator
    Posted 1 year ago #

    WordPress 3.6 is no longer in beta. Please post a new topic.

Topic Closed

This topic has been closed to new replies.

About this Topic