Support » Fixing WordPress » More tag is not working

  • I am using a custom theme that a friend of mine made and I can’t get the more tag to work. Whenever i add it to a post it simply does nothing. All the text after the tag is shown on the main post. Any help would be greatly appreciated as I have scoured the net for an answer and nothing I have tried has worked. Thank You.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi!

    I’m using one of wordpress’ default theme, the Quentin and have the same problem. So I would appreciate any help too 🙂

    This is the page which I would like to split:


    Yup, same problem More tag doesn’t work no matter what I do. Using theme Vita 1.6. Posts to author unanswered. Any help? Below is the code to my index page. Similar code is on the page.php. Thanks in advance.

    <?php get_header(); ?>
    <div id="content-wrap">
      <div id="content">
        <div class="gap">
          <?php if (have_posts()) : ?>
          <?php while (have_posts()) : the_post(); ?>
          <div class="post" id="post-<?php the_ID(); ?>">
            <h2 class="post-title"><a class="intitle" href="<?php the_permalink() ?>" rel="bookmark" title="Permanent Link to <?php the_title(); ?>">
              <?php the_title(); ?>
              </a> <span class="commr">
              <?php comments_popup_link('0', '1', '%'); ?>
            <div class="timr"> Posted on
              <?php the_time('F d, Y') ?>
              <?php the_author() ?>
              <?php edit_post_link('e', '<span class="editr">[', '] </span>'); ?>
            <div class="entry">
              <?php the_content('Read the rest of this entry &rarr;'); ?>
            <p class="postmetadata">
              <?php the_tags('Tags: ',', ','<br />');?>
              <span class="catr">Category
              <?php the_category(', ') ?>
              </span> </p>
          <?php endwhile; ?>
          <?php if(function_exists('wp_pagenavi')) { wp_pagenavi(); } else { ?>
          <div class="navigation">
            <div class="alignleft">
              <?php next_posts_link('&larr; Previous Entries') ?>
            <div class="alignright">
              <?php previous_posts_link('Next Entries &rarr;') ?>
        <?php } ?>
          <?php else : ?>
          <h2 class="center">Not Found</h2>
          <p class="center">Sorry, but you are looking for something that isn't here.</p>
          <?php include (TEMPLATEPATH . "/searchform.php"); ?>
          <?php endif; ?>
    </div> <!-- /gap -->
    </div> <!-- /content -->
    </div> <!-- /content-wrap -->
    <?php get_sidebar(); ?>
    <?php get_footer(); ?>


    Just to double check, are you using this in your post?

    Absolutely. Clicking the button in the post text menu bar (under HTML). There’s code similar to my index page on my page.php as well if that matters. When I publish or preview the page, all the text shows up in a single frame with no “more” in site. I’ve been working around with a hyperlink to a child page but it’s a funky way to do it since I have to redirect comments back to get the comment counter to register on the original post page. A lot of people seem to be having a similar problem…

    Just would like to add my hat to the ring.

    Exact same problem. Not finding solutions.

    It seems that when you add a

    <!-- more-->

    Tag to your entry, it gets crunched into

    <span id="more-###"/>

    Where ### is a unique ID for that particular entries tag.

    Any thoughts out there? We seem to be dealing with a fairly widespread bug here.

    I have managed to resolve this for myself.

    I was tooling around, and fooled around with a few settings. Seems that when the newest WP version needs to be set to full text render to recognize the more tags as we are used to.

    WP Dashboard > settings > reading > For each article in feed show > and switch the radio button to “full text”.

    That fixed it for me.

    Hope that helps someone else!

    I’m also having this problem. I’ve tried changing settings and this and that. It is a custom theme, so I’m wondering if I happened to forget something in the functions page that would keep it from working.

    Hope someone can help us out! Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘More tag is not working’ is closed to new replies.