Support » Fixing WordPress » More tag doesn’t working in RSS

  • Tag <!–more–> which is using for cut big post, doesn’t work on my RSS feed.
    In front page it all good – posts are showing to more tag, but in feed my posts showing fully, I don’t want it.
    In the settings page “For each article in a feed show Full text” is checked.
    This problem appeared after upgraiding from 2.3 to 2.5.

Viewing 13 replies - 1 through 13 (of 13 total)
  • my blog address
    my feed address or

    I wrote a plugin to have the ‘more’ in your RSS feed

    ^ your plugin didn’t work for any of my blogs athos99

    Hello Athos, your plugin works only with the 0.92 rss feed, not the 2.0

    BTW, you may be interested in knowing it is impossible to add a comment on your blog, your captcha is bugged…

    Peeps, this is not a bug, this is how WP is made to behave.

    Give this plugin a try: Better Feed to add “Read more” links (and more things like a copyright notice , a “Add to delicious” or anything you’d like in your feed item footers)

    Well, OZH, I personally feel this is a great mistake to chose to have the RSS feed display the whole blog note.

    My blogging style is to make long, documented, rich blog notes, thought to make fully sense with the contents of my sidebar. That’s what I call blogging. My blog has been gaining more and more visitors, and now with a good choice of ads to display, it’s starting to pay well (as we say in my country, it pays the butter in the spinach), so I take this seriously.

    The “more” tag allowed my visitors to read just enough to decide if they wanted to know the rest or not.

    Now, with the RSS feed making everything shown :
    – I’ve already been kicked out of 2 big aggregators, I am already losing significant traffic
    – I receive more and more trackbacks from splogs that, with utmost ease, can leech 100% of my contents. These splogs naturally steal a bit of your SE traffic.
    Worse, when google sees industrially duplicate contents, both my blog and the splog are punished and lose pagerank and visitors, since google can’t guess which one is the splog.

    All in all, this new feature is plain wonderful. Right ¬_¬

    I’ll look at your plugin, Ozh, thanks for contributing 🙂

    However, since in my case I don’t ever plan to allow my rss to display everything of my posts, and since I don’t need the rest of the nice features your plugin introduces, I’d like to ask you… Is it complicated, or not, to edit manually the core files of wordpress so that the RSS feed stops at the read more and gives a link to the full post, as before ?
    Thanks if you can tell me 🙂

    it doesn’t work. where should I edit the configs?

    Welcome to the wonderful world of WordPress programmers taking something that works and breaking it to make a few people happy.

    The more tag needs to be a cutoff for the RSS feed, or at minimum should be one of the options for your feed. The only two choices right now (under 2.5.x) is a super short quote (useless to most aggregators, and limiting your SE potential) or the full text (often getting people in trouble with the aggregations for having posts that are too long).

    WordPress crew, why the heck did you guys “fix” something that wasn’t at all broken?

    I totaly agree with Rawalex. We need more options for the RSS:

    – with or without HTML
    – with or without more!

    And I try to tweak the feed-atom.php and feed-rss2.php files, but there is always all the article. 🙁
    How can I cut them?!

    Can we have some help please? I really need HTML in RSS, but not with full article! :'(

    Maybe you may use Feedburner for publishing feed as HTML?..

    No thanks, I boycott Google and I don’t need ads in my feed. 😐

    Did anyone figure out? I don’t want to display full article in feed.

    It makes no sense to visit a blog if they can read article in aggregators.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘More tag doesn’t working in RSS’ is closed to new replies.