Support » Plugin: WooCommerce » More Products Per Page Not Working

  • Resolved Erik Gonzalez

    (@miamiwebcompany)


    I cant change the default woocommerce products per page from 10 to anything else. I tried the code from the documentation and nothing. I even tried through the wordpress backend under ‘Reading’ and still only spits out 9. What do I do?

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • gotmedia

    (@gotmedia)

    Hi Erik,

    Not sure if this will work, but try this:

    add_filter( 'loop_shop_per_page', create_function( '$cols', 'return 24;' ), 20 );

    Erik Gonzalez

    (@miamiwebcompany)

    Thank you for the reply @gotmedia but I have tried that also and it still doesn’t work unfortunately.

    Luke McDonald

    (@thelukemcdonald)

    Hi Erik,

    I was experiencing the same issue this morning while working locally where I have Jetpack enabled along with the jetpack_development_mode filter. Removing the jetpack_development_mode filter seemed to fix the issue for me. If you have Jetpack enabled or this filter, try disabling them.

    Luke McDonald

    (@thelukemcdonald)

    Update: More specifically, it turns out the issue was related to Jetpack’s Infinite Scroll functionality. Turning off the Infinite Scroll fixed my issue. Below is a function to disable Infinite Scroll support for WooCommerce if needed.

    function themename_woocommerce_infinite_scroll_support( $supported ) {
    	return ( is_shop() || is_product_taxonomy() ) ? false : $supported;
    }
    add_filter( 'infinite_scroll_archive_supported', 'themename_woocommerce_infinite_scroll_support' );
    Erik Gonzalez

    (@miamiwebcompany)

    Thanks, @thelukemcdonald! It wasn’t jetpack but you made me realize it was probably a plugin causing this and it was. I’m using “Search & Filter Pro” and it was causing the issue. Thanks again!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘More Products Per Page Not Working’ is closed to new replies.