Support » Plugin: Genesis Featured Page Extras » "More Link" still appearing when content limit is set to 0 wpautop

Viewing 6 replies - 1 through 6 (of 6 total)
  • Same problem here. Please fix it!

    Plugin Author daveshine (David Decker)

    (@daveshine)

    @jorwesflow:
    Hi there!

    If you are using the content limit you cannot use wpautop, it will have no effect! The internal used function from Genesis core, the_content_limit() does not accept wpautop and will strip it out. Also it makes no sense logically to use the content limit WITH wpautop, as the “machine” never knows where your HTML tags ends so this could break things!

    You can only use a content limit with a character limit OR full content with or without wpautop.

    All of that is intended behavior!

    The more link will not appear if the more text AND the URL field is empty! So just leave both fields blank. Just tested this again and it works that way!

    Thanks, Dave 🙂

    Plugin Author daveshine (David Decker)

    (@daveshine)

    Hi Francesco Canovi,
    just read my answer above, there is no bug.

    Thanks, Dave 🙂

    Dave, thanks for getting back. I totally understand if the content limit is set to a number above 0 that wpautop is disabled. Makes perfect sense.
    But I’ve always had it set to “0” in the content limit with the wpautop checked, and I’m still having this issue of a blank More Link appearing.

    Here’s a couple screenshots:
    Settings
    More Link

    And here is the webpage in question: http://projectsacramento.com/our-story/ at the bottom of the “Caleb & Chrissy” section.

    Plugin Author daveshine (David Decker)

    (@daveshine)

    Hi, you are right, now I understand what you mean. I work on a solution very soon for new version.

    Thanks for the screenshots!
    –Dave.

    Sounds good! Thanks, Dave. A little display: none will work for now…

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘"More Link" still appearing when content limit is set to 0 wpautop’ is closed to new replies.