Support » Plugin: WP Store Locator » “More info” no longer working with WP 4.9.8?

  • Resolved MichaelNi

    (@michaelni)


    Hi all,

    I set up the plugin for a customer yesterday and changed nothing since. Yesterday, I was able to display the shop description etc. after clicking on the “more info” link (of course, only if the respective setting is activated).

    Today a click on “more info” does nothing (i.e. shows no details, regardless which of the options “Where do you want to show the “More info” details?” is set.

    Can anyone confirm this?

    Best,
    Michael

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Tijmen Smit

    (@tijmensmit)

    What’s the URL? Do any errors show up in the browser console?

    I am having a similar problem.

    Here is the URL:
    https://www.versa-pak.com/distributor-search/

    I have a description entered for ‘BGR – Columbus Office’ and yet it does not even show the ‘More Info’ link, regardless of whether I have the content set to show in the Info Window or the Listing. I’ve cleared the transient cache, my site cache, removed and re-entered the information, and no luck. I also checked the browser console and it shows no errors.

    This is urgent and I need it resolved ASAP.

    Plugin Author Tijmen Smit

    (@tijmensmit)

    The content of the description field is normally not included in the search results template. How to change this is described in this article.

    Thread Starter MichaelNi

    (@michaelni)

    Please read through the question again. That is not the problem.

    The problem is the following:

    • In Settings page: “Show a ‘More info’ link in the store listings?” is activated
    • In Settings page: “Where do yu want to show the ‘More info’ details” > “In the store listings” is set
    • The “More info” links does no longer appear on the frontend. It simply does not show up. It did a few days ago, with exactly the same settings.

    A similar problem appears if “in the info window on the map” is chosen:

    • In Settings page: “Show a ‘More info’ link in the store listings?” is activated
    • In Settings page: “Where do yu want to show the ‘More info’ details” > “In the info window on the map” is set
    • The “More info” links is now shown in the store listings (not on the map!), however, if clicked, nothing happens and the browser only scrolls to the bottom of the page.

    In conclusion, no store details (no opening times, no description, no nothing) is shown on the frontend anymore. As stated before, it did a few days before, I am suspecting before the last WordPress update.

    The console throws no errors. It rather appears that the settings are broken, as “in the info window on the map” produces a “more info”-link in the store listings, which is not the behaviour expected by the administrating user.

    • This reply was modified 2 years, 7 months ago by MichaelNi.
    • This reply was modified 2 years, 7 months ago by MichaelNi.
    Plugin Author Tijmen Smit

    (@tijmensmit)

    My last response wasn’t directed at you.

    Whats the URL?

    Thread Starter MichaelNi

    (@michaelni)

    The URL is http://wp1058820 dot server-he dot de/werkstaetten

    My problem is the exact same as MichaelNi. I cannot get the ‘More Info’ to display at all.

    Plugin Author Tijmen Smit

    (@tijmensmit)

    It shows an error ‘Google Maps kann auf dieser Seite nicht richtig geladen werden.’.

    Did you enable billing in the Google API Console?

    Google changed their model, and now the billing option has to be enabled regardless of the amount of used request. You get $200 free credits a month, which is more then enough for normal users. So if you run a normal site you will never be charged.

    I’m working on adding support for OpenStreetMaps ( which works without a creditcard ), but I’m not done with coding that yet.

    • This reply was modified 2 years, 7 months ago by Tijmen Smit.
    Thread Starter MichaelNi

    (@michaelni)

    Yes, I already switched the new API but set the API limit very low as it’s a development site. The problem exists regardless though, even if I set an higher API limit and if the map is shown fine. Other users report the same problem in this forum post.

    Plugin Author Tijmen Smit

    (@tijmensmit)

    ‘Other users report the same problem in this forum post.’ which doesn’t really mean anything given the fact that a single JS error from any random JS script from a plugin / theme can break it.

    If I click on the ‘more info’ then the info window open. This is not what you expect to happen? The more info in the search results templates only does something when either the phone / fax or email data is set.

    • This reply was modified 2 years, 7 months ago by Tijmen Smit.
    Plugin Author Tijmen Smit

    (@tijmensmit)

    Did you also happen to update your theme? Because the description by itself never really shows up unless you add a few lines of code the function.php inside your active theme folder.

    Thread Starter MichaelNi

    (@michaelni)

    “The more info in the search results templates only does something when either the phone / fax or email data is set.”

    Thank you, this was the information I was looking for. Specifying a phone number now shows the description again. Thought it worked without before. Is there a reason for this behaviour? Personally, I would expect the “more info”-tab to also show the description without adding phone/fax or email data. According to the replies to this thread, it seems like I am not the only one encountering this issue, which seems to be a usability topic.

    I would like top propose the following updates to plugin to improve usability:

    • Add additional checkboxes to specify which information should be found
    • Alter the tooltip “This places a “More Info” link below the address and will show the phone, fax, email, opening hours and description once the link is clicked.” and add a sentence “Description is only shown if either phone, fax or email is set.”

    I realise I can probably change this fairly easy using templates, but I am assuming not all users have the capability to do so.

    Thank you for your replies!
    Michael

    Thread Starter MichaelNi

    (@michaelni)

    Ah alright. That’s probably why I was experiencing this issues. The website is using a theme from Yootheme, they probably supply their own templates out of the box. I’ll check that out. Please ignore my previous statement in this case, even though I think displaying the description or having the possiblity to do so would be a great feature “out of the box”.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘“More info” no longer working with WP 4.9.8?’ is closed to new replies.