WordPress.org

Support

Support » Plugins and Hacks » More Fields (2.1) incompatible with WP 3.3

More Fields (2.1) incompatible with WP 3.3

Viewing 15 replies - 1 through 15 (of 32 total)
  • Martin
    Member

    @martinlucas

    just found the same thing, the WYSIWYG text field is now a tiny box with no tool bar.

    my WYSIWYG field is still OK, but I can’t access the data in my template. it gives me an empty array.

    i just installed this one, it works all right and is even better than MORE FIELDS

    http://wordpress.org/extend/plugins/advanced-custom-fields/

    Merlin Mason
    Member

    @merlin-mason

    I’m getting the same problems with 3.3 and more fields, I think it’s to do with the new way media is uploaded. Anybody know if there’s an update in the works or whether I should tryout this advanced custom fields?

    Catiebugx3
    Member

    @catiebugx3

    I’m not having that problem. Are you sure you don’t have other plugins that conflict with it?

    If I disable More Fields the problem immediately goes away so I’m pretty sure it’s the issue.

    Catiebugx3
    Member

    @catiebugx3

    Yeah, I just noticed I can’t move any of the things around or anything. I’m trying to use Advanced Custom Fields but I’m completely lost on how you make it display. I love how simple More Fields is because you can put in what should be displayed before and after IF there is a value for the field, if there isn’t one, nothing will show up and there won’t be some odd space.

    After using advanced custom fields (http://wordpress.org/extend/plugins/advanced-custom-fields/) I can strongly recommend that plugin! It is much easier to use than more fields, and it even has a decent documentation: http://plugins.elliotcondon.com/advanced-custom-fields/documentation/

    Ray Gulick
    Participant

    @raygulick

    I’ve noticed 2 problems with More Fields in one of my installations:

    1. wysyiwyg boxes in More Fields metaboxes are tiny with no toolbars

    2. all metaboxes on the edit page or edit post screen are “frozen”: can’t open them if they’re closed, can’t close them if they’re open, can’t drag them to another location.

    Both of these problems were noted by others above. When More Fields is deactivated, the metaboxes are “unfrozen.” Of course, the More Fields metaboxes are then gone, so the wysiwyg problem in them is gone also.

    What’s confusing is that I have other sites using WP 3.3 and MF 2.1, and not experiencing the same problems. So it’s possible there is a conflict with another plugin.

    Ray Gulick
    Participant

    @raygulick

    I think I found out how to fix it. For me at least, the problem seems to occur if the standard “Custom Fields” metabox is displaying on the add/edit screens. I added the following code to my functions file to remove the custom fields metabox for both posts and pages, and the problem went away:

    // REMOVE META BOXES FROM DEFAULT POSTS SCREEN
     function remove_default_post_screen_metaboxes() {
    remove_meta_box( 'postcustom','post','normal' );
    }
    add_action('admin_menu','remove_default_post_screen_metaboxes');
    
    // REMOVE META BOXES FROM DEFAULT PAGES SCREEN
    function remove_default_page_screen_metaboxes() {
    global $post_type;
    remove_meta_box( 'postcustom','page','normal' );
    }
    add_action('admin_menu','remove_default_page_screen_metaboxes');
    Ray Gulick
    Participant

    @raygulick

    Spoke too soon; the problem returned. Not sure why it went away temporarily; can’t figure out how to duplicate that.

    I’ve tried a number of custom fields plugins since upgrading to 3.3 and am finding that none of them display the WYSIWYG editor anymore (which makes them useless for me).

    Has anyone found a solution to this, or has anyone from wordpress commented on this issue?

    I have tried
    More Fields
    Advance Custom Fields
    Custom Field Suite

    Ray Gulick
    Participant

    @raygulick

    While it has a couple of minor bugs, I have had good results using Advanced Custom Fields. The wysiwyg fields work fine for me. The really great feature I love is the ability to determine which post types and which page templates a particular custom fields metabox displays on. Also, the repeater field (costs $25; worth every penny) allows you to create repeatable (via “add another” button) custom field sets.

    For more info on WP3.3 known issues, see this post:
    http://wordpress.org/support/topic/troubleshooting-wordpress-33-master-list

    Thanks Ray.

    But, I just installed and checked Advance Custom Fields again, and I am not getting the WYSIWYG editor at all. I specifically need to use the HTML editor.

    All I get in WP 3.3 is the text box with the Upload icon above the box. None of the WYSIWYG icons are visible.

    Is this not the case for you?

    Ray Gulick
    Participant

    @raygulick

    Not the case for me: wysiwyg editor fields in ACF showing up and doing the job.

    Wild guess: this might be a jquery version issue? I’m loading jquery 1.6.2 from google cdn; not using 1.7.1 packaged with WP3.3.

    You might look carefully at the master list for more clues.

Viewing 15 replies - 1 through 15 (of 32 total)
  • The topic ‘More Fields (2.1) incompatible with WP 3.3’ is closed to new replies.