Support » Fixing WordPress » more erratic behavior after updating to 3.8

  • Also now it is screwing up my Pali diacritics.

    With the font stack

    font family: “Times New Roman”, “Times Roman”, Times, Georgia, “Bitstream Charter”, serif;

    I had been able dependably to display diacritics in the chosen font family for the Pali language. Now it is somewhat randomly reverting to a monospaced typewriter font for most diacritics. Sometimes staying with that through the rest of the word, other times just for the letter with the diacritic.

    Yes, I know that code draws from my computer’s fonts. But (1) I’m viewing it on the same computer with the same fonts, and (2) these seem so ubiquitous in their extended unicode versions that every OTHER computer I’ve checked it on (in the past 2 years) also displayed these fine.

    And now, not. Not on my same old computer with the same fonts, that is.

Viewing 10 replies - 1 through 10 (of 10 total)
  • esmi


    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    Sorry, this was a followup to a post recounting several OTHER erratic behaviors.

    YES, as I stated there, I HAVE tried deactivating all the plugins.

    Haven’t tried resetting plugins folder by FTP. Tho from the flood of spam comments this afternoon it seems clear that Akismet, at least, is effectively deactivated! 😉



    Forum Moderator

    And the other steps?

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Your other post is here:

    I am getting some very odd behavior after updating to 3.8.

    I am running a child theme of Twenty Ten. I’m running 4 plugins: Akismet, AutoExcerpt Everywhere, Random Text, and WP Super Cache. (See #5 below, yes I inactivated all of them eventually.) This site configuration has been together and working fine since late winter 2012–nearly two years.

    (1) (Most annoying.) My base url opens a specific (and rather old) post, not the front page that aggregates all the most recent posts. It does this in Safari, Firefox, Chrome, and Opera. The browser address line shows only the base url, but the title up at the top of the browser window shows the post title. Emptying the cache changed this in Chrome, but after I closed and reopened Chrome the problem was back. I’ve tried re-saving Permalinks–no help. I’ve looked for the place in Settings where one specifies posts or a static page–not there. The annoying new “Customize” feature already had “Your latest posts” chosen, but I resaved it with that choice anyway. This fixed the problem in Safari, but not the others. And when I logged out of my site, the problem was back in Safari. too!

    (2) The admin bar that shows at the top on the public side when logged in was missing for a long while (while I was going back and forth, editing a post). There was no “Edit” link at the end of the post I was working on, either. Yet the back button on Safari got me back to the edit window just fine. Then, the bar reappeared, along with the “Edit” link.

    (3) I added new tags to the post, but the tag cloud (in footer) did not update. I clicked “delete cache,” no change. I re-saved the tag cloud widget. I went to settings and turned WP Super Cache off, then on again. I manually deleted the cache, did a preload–no change to tag cloud.

    (4) When I turned WP Super Cache off, the “delete cache” button disappeared from the admin button across the top. When I turned it on again, that button did not reappear, though the bar remained there.

    (5) I deactivated ALL of my plugins. No update to tag cloud. And that one rather old post showing when browser is pointed to the base url–or when site title clicked–or when return to site chosen after log out.

    (I’ve closed the other post since having two makes more work for everyone right now)

    Since they were separate and different problems, which may have separate and different causes (though ALLLL seem linked to the update to WP3.8, and probably NOT something I am doing wrong), I had been feeling guilty about not making one post per issue!

    I’m at work now and can’t do more troubleshooting till tomorrow.

    I suspect the trouble with the fonts has to do with not overriding a browser’s spec that was other than UTF-8 (which is what I need)–somehow with previous versions of WP it was successfully asserting this spec and now is not–???

    Wonderful–just lost my reply!!

    (1) and (2) above–old post instead of front page, and no admin bar–resolved themselves, seemingly with no change. Random behavior is NOT good, but scary….

    Now I have reset plugins via FTP, and switched back to Twenty Ten, the parent theme of my child.

    (3) Tags added to published post two days ago have still not appeared in tag cloud.

    (4) Have not activated WP Super Cache, so no idea how it is doing.

    Issue of second post: diacritics still messing up in Opera. Fine in Safari (with UTF-8 specified in preferences), Firefox, Chrome. Is this an encoding spec issue, and if so can I add something to tell the browser to use UTF-8?

    New issue: comments-title (“responses to”) and comments-title em (post title) have same styling, and have previously displayed the same. Suddenly, the em text was very large and in the wrong font. I made the css more redundant, and got it into the right font but still large. Deleting the em and close em from the comments.php file in the child theme caused all comments to disappear, so I restored the line from the parent theme.

    I have returned to my child theme, as its parent Twenty Ten seems to have the same issues. Have re-activated Akismet, plus Random Text and Auto Excerpt Everywhere, as they seem not to be the problem and are part of how I choose to present my content. It is tempting to conclude that 3.8 just isn’t a stable release yet… I certainly won’t be updating to it just yet on any other sites I have control of. But it would be good if THIS site returned to displaying correctly!

    Tag cloud hit its preset limit of 45 tags–I figured out how to change that to 60 in functions.php.

    I am still getting the admin bar visible/not visible on the front. Once more the “edit” link also disappeared from the front, for a while. Then it re-appeared but wasn’t working.

    I removed the em tag from the post title in the comments “invitation” in comments.php (in my child theme). I still don’t see why it suddenly started displaying differently, after many months of displaying the same.

    Still incorrect display of diacritics in some browsers–some browsers pull up the more exotic parts of the unicode fonts (I’m using Times New Roman, Times Roman, Times because, between them, generally those extended sections are present for one of these fonts). And refusing to pull up the same extended sections–same computer, same fonts to work with–in other browsers. Any ideas?

    Any ideas?

    Deactivate ALL plugins and switch to a current default theme?

    Deactivate ALL plugins and switch to a current default theme?

    Yup, I deactivated all plugins, including temporarily renaming plugins folder via FTP. Switched to Twenty Ten. Same problems. ThenI returned to child theme and essential plugins (just 2 + Akismet).

    want to look at these errors which may or may not be problematic:

    html5: tag-closing errors in one text widget–checked “Automatically add paragraphs” AND used some em tags–unchecked, did my own paras, no problem. 2 places in footer it wanted a space–done
    css: “errors” are all “webkit-text-size-adjust” and all identical to what’s in the Twenty Ten parent theme

    Opera is still screwing up my diacritics. And is NOW displaying each page I open in the parent theme! Reverts when I refresh the page. It was more than 24 hours ago that I had the parent theme active, and I have looked at the site in Opera today, so I’m not thinking browser cache. And I have not reactivated WP Super Cache. Any ideas?

    Time will tell about the disappearing and reappearing admin bar… will return with results in a day or two.

    Already I have found the “edit” link at the end of a post visible, looking like a link, but not responding–when the “edit post” link on admin bar worked fine (that time).

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘more erratic behavior after updating to 3.8’ is closed to new replies.