Support » Plugin: Wordfence Security - Firewall & Malware Scan » More Backup Buddy Issues

  • Today, I’ve had two – update, now three – of my sites report an issue with Backup Buddy not being able to complete its tasked full backups. Looking at the logs, it’s having issues with the Wordfence database tables, specifically…

    Error #857835: Unable to get table creation SQL for tablewp_wfhoover`. Result:
    1. Verify that it exists and mysql permissions allow this. If you manually included this as an additional table, make sure it is the correct table name.`

    iThemes does not have any information on that error number.

    The only way I got Backup Buddy to run properly was to deactivate, uninstall and then use Wordfence Assistant and drop the database tables. Then it ran. Then I reinstalled Wordfence, set it up and tried to run Backup Buddy again and it ran.

    Then a couple hours later I have a second site with the same issue. Neither have been able to backup anything in the last three days.

    Any ideas here?

    Additional information. In both cases, when I log into phpMyAdmin, and take a look at the wp_wfhoover database, it. shown as “in use.” Never seen that before. Screenshot here – https://pasteboard.co/IXhErEl.jpg

    When I had Backup Buddy SKIP that particular table, the process ran, but it did seem to kick back an error during the process but I think the backup did complete.

    Here was the reply from iThemes Support when I asked them about the issue:

    Mar 2, 15:13 CST

    Hi Steve,

    I’m seeing the following from that log:

    14:59:21.50 64.28sec 26.62MB Error #857835: Unable to get table creation SQL for tablewp_wfhoover. Result: 1 . Verify that it exists and mysql permissions allow this. If you manually included this as an additional table, make sure it is the correct table name.
    And as you mentioned, it seems to be for a Wordfence database table:
    wp_wfhoover

    This indicates that BackupBuddy asked the database server for the sql statement(s) that would create the table in a new database but the database server was unable to return those details for some reason. This could indicate some corruption in the database for example, but unfortunately, we don’t have any additional information in this case, sorry.

    You can refer to your host support who will be able to investigate the database problem on their server with much more detail than either you or we can and should be able to resolve the problem for you. Ultimately you may need to refer to the developers of the associated plugin for advice on how to recover.

    Though others have issues with Wordfence database tables in the past:
    http://www.webhostingtalk.com/showthread.php?t=1443660
    https://wordpress.org/support/topic/crashed-wordfence-database-tables-keeping-backups-from-running/
    https://wordpress.org/support/topic/table-details-warning-with-wordfence-installed/
    https://wordpress.org/support/topic/table-wp_wfhits-is-marked-as-crashed-and-should-be-repaired/

    Please let us know of any update and we may be able to advise further if required.

    • This topic was modified 1 year, 10 months ago by steve49589.
    • This topic was modified 1 year, 10 months ago by steve49589.
Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘More Backup Buddy Issues’ is closed to new replies.