Support » Fixing WordPress » Monthly Archives listing months wrong

  • I’m using v. 1.0.2
    The problem is, as you can see here, is that the monthly archives are listing as Year only. I’m using the get_archives(‘monthly’) function, as no other variation will work, and that’s fine.
    So, am I missing something in the templates_function file? It correctly links to the right months, I’d just prefer they display more than the Year on the list.
    TIA – Nik

Viewing 15 replies - 1 through 15 (of 19 total)
  • Bueller… Bueller… 😉
    I guess I’m on my own with this one.

    I’m getting the same problem, and I AM using WP 1.2. It’s not just you, Nikki.

    Thanks, Shelby. Let me know if you get it figured out, and I’ll email you if I do.

    I’m having the same problem :/

    Doesn’t fix it 😉

    I’ve tried using get_archives, I’ve carefully constructed tag parameters and modified them a million times. I’ve tried not defining any parameters except the archive type. I’ve tried defining every parameter. I’ve tried wp_get_archives. Nothing corrects it. 🙂
    Thanks for the suggestions, though, because it definitely helps to make sure that you’re defining things properly.
    The funny thing about this issue is, though, that it generates the links. It points to the right URI. It just fails to output the month name in the link text. So, all you get is a list of links that all say “2004,” even though each one points to the right URI for its month.

    Incidentally, listing by weekly, or by category is not a problem.

    I’m using the Mingus 1.2 .. I’m calling only 6 months of archives below, at it is working fine. Maybe try sticking in the last parameter?
    < ?php get_archives('monthly', '6'); ? >

    Tried that, but it doesn’t help. 🙂 It’s not a get_archives tag issue, we’ve already exhausted every possible param there.

    Shelby, I tried to access your site but it kept hanging for me, so I’m posting here again.
    Ok, I did an upgrade to 1.2 – then began implementing my old layout line by line into the new index.php file. It turns out that there was some kind of conflict with a simple php countdown script I had. Once I removed it, voila. Archives show up like they’re supposed to.
    Now, on to post a slightly different problem question…

    Yeah, sorry about that Nikki – it was hanging because of – guess what?! A plugin for WP. 😉 It should load perfectly fine now. For three or four days now, though, I’ve been wondering if my hosting company just all of a sudden went downhill. 😛
    The thing that bothers me about this is, I use the same scripts, and the same code in every layout, because I have all the files seperated as includes – however, I have several different skins.
    Some skins display the archives perfectly. Some skins do not. Yet, all skins have the same scripts and whatnot running on them.
    However, I will at least make an attempt to pull out things one by one to find out what causes it. Thanks!

    I figured out what it was – it was the very first thing that I pulled out of the code.
    But that frustrates me to no end – because what I pulled out of the code was my event calendar!! (phpCalendar, from – I kind of liked having that particular event calendar… but I suppose if I must choose between decent archives and my event calendar, the archives will win out.
    Thanks for the suggestion, Nikki!

    Glad we both got that figured out! 😉

    I have the same problem and use phpCalendar. I tried pulling it out but my archive months are still not showing.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Monthly Archives listing months wrong’ is closed to new replies.