Support » Fixing WordPress » Monthly and daily archives links problem

  • Hi,

    Does anybody know why if i have permalinks set up like this:
    /%year%/%monthnum%/%day%/%postname%/
    all is working right (i’m getting http://mysite.com/2005/06/ as expected)
    and if i set up them like this:
    /%year%/%monthnum%/%day%/%postname%-%post_id%/
    all of a sudden i have the word “date” inserted it my monthly and daily archives links structure like this:
    http://mysite.com/date/2005/06/

    Thanks in advance.

Viewing 7 replies - 1 through 7 (of 7 total)
  • “Does anybody know why”

    Nope. And I just adjusted a couple blogs to that permalink structure with no ill effects.

    Version of WordPress and server info?

    I’m currently testing it on my home Windows XP. WordPress version – 1.5.1, all changed files from 1.5.1.3 copied inside.

    Aha!
    It appears that i found the reason: in classes.php there is a function get_date_permastruct() where this is set up: “Do not allow the date tags and %post_id% to overlap in the permalink structure. If they do, move the date tags to $front/date/”.
    If i comment it – all works well. Does it really needed or it can be commented safely?

    I suspect you should be fine, since in your case you’re not really running into the problem of overlapping.

    Thanks!
    I’m wondering now how this could be that you didn’t faced to this problem if you’ve set up your blogs like this as you say?

    I tested it on two setups, one being XP as well (IIS). I modify quite a bit of the WordPress core, but nothing in relation to permalinks. I can’t say why the difference.

    Might want to report it as a bug, and link back to this thread.

    Thanks again.
    The ticket’s system is down for me right now, i’ll try to do it later.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Monthly and daily archives links problem’ is closed to new replies.