Support » Plugin: Mollie Payments for WooCommerce » Mollie doesn’t autocomplete orders

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Guido Scialfa


    Hi @forevah

    I tried to replicate the problem without success.
    I see the order correctly set as Completed.

    I notice the order is marked as completed when the client reach the Order Received page. I tested by setting the autocomplete for paid and unpaid orders.

    > But when completing payment with Mollie the orders are NOT set to paid.

    As far as I understanding the plugin just change the order status in WooCommerce this does not affect the order status in your Mollie account.

    Could you give us some more info of how to replicate the problem?

    The autocomplete plugin should indeed just change the order status in Woocommerce to paid but it doesn’t.

    Steps to reproduce:

    1. Buy something & go to checkout
    2. Pick any Mollie payment method
    3. On Mollie website, mark order as ‘paid’ (test mode)
    4. (Mollie redirects back to the website*)
    5. A success message screen appears
    6. Problem: order is NOT marked as ‘completed’ in WooCommerce (it still is ‘pending’ there)

    * It might be related to another bug for multilingual shops:

    Plugin Author Guido Scialfa


    There’s no paid order status in WooCommerce as you can read in their documentation

    May be you’re using an additional plugin?

    Anyhow from what I see the Autocomplete Order just set an order to completed based on a setting.

    That order even if marked as completed does not mean its has been paid.

    I followed your instructions but for me the order goes in completed.

    Could you try to deactivate all plugins except for WooCommerce, Mollie and Order Autocomplete and try again?

    If the problem persist, switch to a default WordPress site and check it again.

    If you still experiencing the issue please contact us at because probably we need to debug further to understand what’s going wrong.

    Thank you

    Hi Guido,

    You are right about the “completed” state (I meant that instead of paid). But it keeps being ‘pending’ instead of completed.
    Could it be caused by test-mode of Mollie or the redirect-error mentioned here:

    If you test it with PolyLang, does it work?

    Thanks for your help

    Plugin Author Guido Scialfa


    Hi @forevah,

    Don’t know if that could depends by Polylang but I do not think that’s related with WooCommerce api endpoint.

    I tested Mollie with the latest version of Polylang and Polylang for WooCommerce and I didn’t had that issue.

    Did you tried what I suggested in my previous comment?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Mollie doesn’t autocomplete orders’ is closed to new replies.