Support » Plugin: Mollie Payments for WooCommerce » Mollie broken

  • Resolved fdittmar

    (@fdittmar)


    After last Woo and Mollie update tonight things went bad. No payment methods shown even though in the Woo dashboard it says Mollie is online. The log error shows:

    2020-08-20T19:30:53+00:00 DEBUG getApiPaymentMethods: Could not load Mollie methods (live): Error executing API call (400: Bad Request): The billingCountry is invalid. Field: billingCountry. Documentation: https://docs.mollie.com/guides/handling-errors (Mollie\Api\Exceptions\ApiException)

    Any idea?
    Urgent as my site is effectively without payment methods now..

Viewing 7 replies - 1 through 7 (of 7 total)
  • Thread Starter fdittmar

    (@fdittmar)

    This seems to be caused by a payment method being switched on (Direct bank transfer).
    Switching if Off does this to the logs:

    2020-08-21T07:23:23+00:00 DEBUG getApiPaymentMethods: Could not load Mollie methods (live): Error executing API call (400: Bad Request): The billingCountry is invalid. Field: billingCountry. Documentation: https://docs.mollie.com/guides/handling-errors (Mollie\Api\Exceptions\ApiException)
    2020-08-21T07:26:17+00:00 DEBUG Mollie_WC_Helper_Data::deleteTransients: Mollie settings saved, delete transients

    https://prnt.sc/u3b6ke

    Am back on 5.8.1 and Woo 4.4.0

    How does one fix it?
    Thanks

    Plugin Support Andreas W.

    (@aweissinpsyde)

    Hello @fdittmar

    can you please send us log files and the WooCommerce status report to mollie@inpsyde.com Please add the link to this thread in your email, please.

    Best regards
    Andreas

    Same problem here. All payment options are hidden in the checkout screen before selecting an country. This is very urgent

    2020-08-26T09:16:45+00:00 DEBUG getApiPaymentMethods: Could not load Mollie methods (live): Error executing API call (400: Bad Request): The billingCountry is invalid. Field: billingCountry. Documentation: https://docs.mollie.com/guides/handling-errors (Mollie\Api\Exceptions\ApiException)

    • This reply was modified 7 months, 3 weeks ago by Niek.
    Plugin Support Andreas W.

    (@aweissinpsyde)

    Hello @fdittmar can you send me some log files, please

    @nvomedia please check your billing country. it seems the country you want to use isn’t supported currently

    @aweissinpsyde it’s the Netherlands, that is fully supported I suppose since that’s the same country as Mollie šŸ™‚
    I hardcoded the customer billing country in a function to NL now and that is working.
    https://docs.woocommerce.com/document/change-the-default-state-and-country-on-the-checkout/

    Plugin Support Andreas W.

    (@aweissinpsyde)

    @nvomedia

    thanks for your update

    Have a nice day
    regards
    Andreas

    Plugin Support Andreas W.

    (@aweissinpsyde)

    Closed because of inactivity

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Mollie broken’ is closed to new replies.