Support » Plugin: Hyper Cache » ModSecurity stop Hyper Cache saving option “Use readfile()” cause 403 error

  • Imidg

    (@imidg)


    Hi! I’ve got a problem with Hyper Cache on some hosting where ModSecurity is on.
    It does not allow to save options, because of option “Use readfile()” since it has name ‘readfile’ and ModSecurity blocks it.

    [Wed Feb 14 22:18:43 2018] [error] [client 93.81.45.108] ModSecurity: Access denied with code 403, [Rule: ‘REQUEST_COOKIES|!REQUEST_COOKIES:/__utm/|!REQUEST_COOKIES:/_pk_ref/|REQUEST_COOKIES_NAMES|ARGS_NAMES|ARGS|XML:/*’ ‘(?i)(?:\b(?:f(?:tp_(?:nb_)?f?(?:ge|pu)t|get(?:s?s|c)|scanf|write|open|read)|gz(?:(?:encod|writ)e|compress|open|read)|s(?:ession_start|candir)|read(?:(?:gz)?file|dir)|move_uploaded_file|(?:proc_|bz)open|call_user_func)|\$_(?:(?:pos|ge)t|session))\b’] [msg “Php”]

    If I change option name to ex.’read_file’ – then it has no problem with ModSecurity.

    Please, can you change name of the option “Use readfile()” to ‘read_file’ or something else, to prevent ModSecurity blocking?

  • The topic ‘ModSecurity stop Hyper Cache saving option “Use readfile()” cause 403 error’ is closed to new replies.