Support » Plugin: Yoast SEO » “modified plugin file” says Wordfence?

  • Resolved lukefive

    (@lukefive)


    I got email today from Wordfence security about these four files:

    * Modified plugin file: wp-content/plugins/wordpress-seo/languages/wordpress-seo-nl_NL.json
    * Modified plugin file: wp-content/plugins/wordpress-seo/languages/wordpress-seo-pt_PT.json
    * Modified plugin file: wp-content/plugins/wordpress-seo/vendor/autoload_52.php
    * Modified plugin file: wp-content/plugins/wordpress-seo/vendor/composer/autoload_real_52.php

    Searched this forum but nothing found.

Viewing 15 replies - 1 through 15 (of 18 total)
  • Same issue on my sites.. Did anyone knows something about..?

    Thanks

    Same for me.

    DON’T TRY TO REPAIR THEM – CAUSES A FATAL ERROR!
    I deleted, then reinstalled the plugin, ran a new scan, same issue.

    I have sent a report to WORDFENCE, and awaiting response.
    YOAST – any info from you guys please?

    Many thanks
    Stevo

    • This reply was modified 4 years, 6 months ago by Stevo.

    I got the same WordFence alerts, so at least I don’t think we’ve all been hacked.

    Alert generated at Thursday 8th of March 2018 at 07:17:24 PM
    Warnings:
    * Modified plugin file: wp-content/plugins/wordpress-seo/languages/wordpress-seo-nl_NL.json
    * Modified plugin file: wp-content/plugins/wordpress-seo/languages/wordpress-seo-pt_PT.json
    * Modified plugin file: wp-content/plugins/wordpress-seo/vendor/autoload_52.php
    * Modified plugin file: wp-content/plugins/wordpress-seo/vendor/composer/autoload_real_52.php

    Have spoken to Wordfence, who have looked at the issue.
    They say sit tight and await YOAST response.

    Hey ho….
    Stevo 🙂

    Same here, 20+ sites reporting with these warning this morning, basically every site running Yoast, and across several different hosts.

    Also:

    Modified plugin file: wp-content/plugins/contact-form-7-mailchimp-extension/lib/view.php
    Modified plugin file: wp-content/plugins/contact-form-7-mailchimp-extension/readme.txt

    The changes in those two look innocuous enough, and they were resolved by deleting and re-installing the MC plugin.

    Same here with 8 sites running Yoast.

    Alert generated at Friday 9th of March 2018 at 05:04:40 AM

    Warnings:

    * Modified plugin file: wp-content/plugins/wordpress-seo/languages/wordpress-seo-nl_NL.json

    * Modified plugin file: wp-content/plugins/wordpress-seo/languages/wordpress-seo-pt_PT.json

    * Modified plugin file: wp-content/plugins/wordpress-seo/vendor/autoload_52.php

    * Modified plugin file: wp-content/plugins/wordpress-seo/vendor/composer/autoload_real_52.php

    We’ve discover that every site that runs Yoast 7.0.2 have this issue but what Yoast say about..????

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    We apologize for any inconvenience. We recommend you please remove the Yoast SEO plugin and reinstall it on your site to check whether this resolves the warning you’re receiving.

    Please, let us know whether the issue persists.

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    We have opened a bug report in our development repository regarding this that you can find and follow the progress of the report here: https://github.com/Yoast/wordpress-seo/issues/9178

    I see that the issue is not present in all sites, I’ve checked several site but just someone are affected.. Remove and reinstall Yoast is a not easy practice, so please solve.. Thanks

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    We have released Yoast SEO v7.0.3. Can you please update your Yoast SEO plugin to the latest version to check whether this resolves the issue?

    Is really weird, I’ve not updated yet but wordfence says there’s all ok, no more modified files.. Did was a wordfence issue..?

    * Could have been that Wordfence’s suppository was not updated in time
    * Could be YOAST pushed a few quiet updates

    Not too worried!
    All working fine now.

    Thank you YOAST & WORDFENCE for your help with this 🙂
    Stevo

    MariusG

    (@marius_codeinwp)

    Thank you both for confirming that the issue has been fixed.

    @lukefive, are you still experiencing this issue or has it been fixed in the meantime?

    Thread Starter lukefive

    (@lukefive)

    Like other site managers, I am seeing that WordFence is no longer sounding alarms.

    I understand that plugins need to initiate processes. The industry expectation is that the better-known plugins will be designed to peacefully co-exist in the WordPress environment.

    Thank you @marius_codeinwp for checking on my status.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘“modified plugin file” says Wordfence?’ is closed to new replies.