Support » Plugin: Payment Plugins for Stripe WooCommerce » Mode: live. Invalid secret key. Please check your entry.

  • Resolved victort

    (@victort)


    I cannot receive payments from my customer. When I click on “connection test” in live mode, below error message is shown:

    “Mode: live. Invalid secret key. Please check your entry.”

    While with Stripe for Woocommerce, I have no place to enter my keys for live mode. My only solution to this is reinstalling the plugin. But the problem happens again in just a few days.

    I cannot bear the risk to explain to my customers, telling them my plugin is not working to receive payment. Hope someone can help, thanks!

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Payment Plugins

    (@mrclayton)

    Hi @victort,

    While with Stripe for Woocommerce, I have no place to enter my keys for live mode. My only solution to this is reinstalling the plugin. But the problem happens again in just a few days.

    You don’t need to re-install the plugin. Just click the “Connect to Stripe” button to connect the plugin in live mode.

    But the problem happens again in just a few days.

    It sounds like your API keys are either being delete from your WordPress database, or they are being expired in Stripe. Option one is more likely I believe. If your API keys are being deleted from your database then there is something else going on with your site not related to Stripe. The Stripe plugin never deletes this data so I recommend you check what kind of other plugins you have installed that might affect your database.

    Kind Regards,

    Thread Starter victort

    (@victort)

    Appreciate your prompt reply!

    I have tried clicking on “Click to Re-connect” button and type in my Stripe credentials, but it’s not working, problem still exists.

    That’s why I have to reinstall the plugin. Thanks!

    Plugin Author Payment Plugins

    (@mrclayton)

    Hi @victort,

    Re-installing the plugin doesn’t do anything though. The plugin doesn’t delete its data when you un-install so I am not sure what you re-installing fixes for you.

    have tried clicking on “Click to Re-connect” button and type in my Stripe credentials, but it’s not working, problem still exists.

    So when you re-connect and perform a connection test it fails? Or does the connection test work, then some time later it starts to fail?

    When you perform the connect process do you see the confirmation message on the API Settings page that everything is connected?

    Kind Regards,

    Thread Starter victort

    (@victort)

    When I click re-connect, it fails immediately (never succeed). Last time I solved the problem is via reinstalling the plugin (without clearing the data), but it works then.

    When I perform the connect process, it’s like:
    1. Click the “re-connect” button
    2. Login to Stripe
    3. Choose the Stripe account to connect
    4. It loads a while and redirect me back to the wordpress plugin page.

    Thanks!

    Thread Starter victort

    (@victort)

    I have reinstalled the plugin this time, but it cannot be resolved now.

    Still, after I click reconnect, it asks me to login and connect to a stripe account, after that, the connection test still fails and keeps telling me my secret key is wrong.

    Plugin Author Payment Plugins

    (@mrclayton)

    Hi @victort

    Please see my previous question regarding whether you see a success message or not once you are redirected back to your WordPress admin.

    Did you attempt to find a plugin conflict?

    This issue would not be caused by the Stripe plugin. Something is interfering with either the connect process or the database entries.

    Kind regards

    Hi @victor, did you figured out what happened on your site? the same happening to me too.

    It worked for a few days then even if I reconnect it says on the test “Mode: live. Invalid secret key. Please check your entry”.

    Plugin Author Payment Plugins

    (@mrclayton)

    Hi @kisatom

    Log into your stripe.com account and see what the status of your account is. It’s possible Stripe has put a hold on your account until you provide certain information they require to process live payments.

    If you provide your account ID I can also check the status of your account within Stripe.

    Kind regards

    Hello, my status seems ok, my ID is: acct_1IQ60eKad5MWkwzv

    Thank you for your help!

    Plugin Author Payment Plugins

    (@mrclayton)

    @kisatom,

    Your account status looks fine after reviewing. I reviewed your account logs and I see quite a few successful API requests from 9/12/21 but none today (9/13/21). That makes me suspect a firewall rule on your server is the culprit.

    Make sure that your server can make outbound requests to Stripe’s servers.

    Kind Regards,

    Thread Starter victort

    (@victort)

    Hi, my problem is solved. It should be a conflict between this plugin and another plugin called eform (I guess it is related to their ability to receive Stripe payments).

    I inactivated all plugins and reactivated them one by one, so I found out this conflict.

    Btw, I’m gonna shoot a big 5-star for Mr. Clayton’s prompt reply, it is awesome for support of free plugins, highly appreciated it!

    Plugin Author Payment Plugins

    (@mrclayton)

    Hi @victort,

    Thank you for updating on what the issue was. Do you have a link to that eform plugin? I’d like to contact them to make them aware of the conflict.

    Kind Regards,

    Thread Starter victort

    (@victort)

    That’s great, their product link is:
    https://eform.live/

    and it is also sold on envato:
    https://codecanyon.net/item/eform-wordpress-form-builder/3180835

    Thanks!

    Plugin Author Payment Plugins

    (@mrclayton)

    @victort,

    Unfortunately the only way to contact them is to provide proof of purchase. Perhaps you can contact them and direct them to this support thread.

    Kind Regards,

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Mode: live. Invalid secret key. Please check your entry.’ is closed to new replies.