• Resolved aojohnson

    (@aojohnson)


    If a user opens any of the Photonic albums (from smugmug), and then opens the ‘Request Service’ modal form (Caldera Forms), the gallery lightbox reopens over the form when trying to open the form?? If the ‘service request’ form is opened first, it works fine.

    I’m guessing they are using the same js trigger or something. How can I overcome this?

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Sayontan

    (@sayontan)

    Does this happen if you switch to a different lightbox?

    I’ve tried several and yes, it does.

    Plugin Author Sayontan

    (@sayontan)

    This took considerable effort to troubleshoot and I had to install Caldera and put in a bunch of debugging statements throughout one of its scripts.

    This looks to be a 3-way problem with remodal in conjunction with Photonic and the fact that both have some sort of deep-linking behaviour. Basically whenever either plugin is presuming a change in the deep-link (i.e. the part of the URL with a “#” in it), it is triggering a cascade of events and causing the lightbox to open (basically Photonic finds a previously opened deep-link when Caldera triggers a deep-link change).

    Now, Photonic has a method to block deep-linking (Photonic → Settings → Lightboxes → Common → Deep Linking), but while it disables the Photonic deep-link, it doesn’t prevent the hash change method from triggering. I will put in a fix for this in the next iteration.

    In the meanwhile, it might help to check if Caldera has a way to disable its deep-linking as well.

    Thank you so much for checking on this. Your support is incredible!

    I’ve reached out to the folks @ Caldera Forms as well, and hoping to hear back and get this resolved.
    Thanks again.

    Plugin Author Sayontan

    (@sayontan)

    Please try this with version 2.27. I think I have made some changes in Photonic that will help you if you disable Photonic’s deep linking as per my previous post.

    aojohnson

    (@aojohnson)

    I’ve updated, but the issue persists.

    Plugin Author Sayontan

    (@sayontan)

    And you have disabled Photonic’s deep-linking? It seems to be active on your site.

    aojohnson

    (@aojohnson)

    Ah, yes! It is working now. Thank you!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.