Support » Plugin: Image and video gallery from Google Drive » Mod_Security Error Message when Granting

  • Resolved essenceval

    (@essenceval)


    Good evening,

    I have followed all steps as directed but I am getting the following error message when granting permissions “An appropriate representation of the requested resource could not be found on this server. This error was generated by Mod_Security”

    I wanted to start a threat in case others are having the same issues. Any help would be greatly appreciated.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author genabitu

    (@genabitu)

    Hi, thanks for the report
    yeah, as you wrote, this is an issue caused by the security module for Apache.

    We will look into this issue more, but as a workaround I recommend switching mod_security off while granting the permissions (and then switch it back on ideally as it is a security feature)

    Here is how to do it: https://stackoverflow.com/questions/12928360/how-can-i-disable-mod-security-in-htaccess-file

    Does that help?

    Thanks,
    Marek Dědič

    Thread Starter essenceval

    (@essenceval)

    I wanted to reply for anyone else having the same issue.

    The solution above did not work for me. Simply modifying .htaccess was not working, I had to contact my hosting provider and request them to whitelist this plugin on the server itself so it will now work for any website being hosted in this server.

    Thank you for the quick reply and amazing plugin @genabitu

    Plugin Author genabitu

    (@genabitu)

    Hi,
    thanks for the write-up.
    We’ve encountered this issue for the third time now – I’ve created a tracking issue on our GitHub tracker as well – https://github.com/skaut/skaut-google-drive-gallery/issues/99

    Hopefully, we can test this with mod_security somewhere and fix this issue once and for all.

    Plugin Author genabitu

    (@genabitu)

    Hi, I am looking into this and how to maybe prevent the issue going forward, but I have no luck – the plugin works for me even with the security module turned on. Could you maybe ask your provider what was the issue? Or something to get us going… You can send it to genabitu@gmail.com

    Thank you,
    Marek

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Mod_Security Error Message when Granting’ is closed to new replies.