Support » Fixing WordPress » Mod_Rewrite Seems Bugged

  • Hey,

    How can i use the mod_rewrite correctly?
    I’m trying host my own blog. then i can set some packages on my server.

    Reading the documentation i see as prerequisite 2 modules of apache, then i did:

    a2enmod expires
    a2enmod headers

    Now in the plugin Advanced tab the option never changes from “Legacy page caching”…

    Before enable the modules was “Use PHP to serve cache files”

    And all times i tried the option: “use mod_rewrite to serve cache files”, never worked…

    I did a copy from the code on button and updated the .htaccess files, so my blog got blank pages, then i removed the code and everything back to work. But or only in “Use PHP to serve cache files” without modules expires / headers disabled or only “Legacy page caching.” if expires and headers mode are enabled.

    This is an bug?

    Another issue i noticed is my server get high load, 100% of processor dropping all others servers (i’m using vmware machines 1 firewall / 2 dns / 1 mail server / 1 database server / 1 webserver) all in same box, then the plugin make all freeze, disabling this plugin this doesnt happen…

    My setup is:

    Quad Core Extreme 3.2 Ghz 12 MB cache
    16 GB RAM

    Virtual Machines (all with 2 processors)

    1 Firewall PFSense (2 GB RAM)
    1 DNS Server – Debian (256 MB RAM)
    1 DNS Server – Debian (256 MB RAM)
    1 Database Server – Debian (756 RAM 2)
    1 Webserver – Debian (7 GB RAM)
    1 Mail server – Debian (756 MB RAM)

    Hosting only one blog and get the issue of from 100% processor locked in webserver using the WP Super Cache without modules expires and headers enabled

    PS.: For the setup of server i used the ISPConfig

  • The topic ‘Mod_Rewrite Seems Bugged’ is closed to new replies.